Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641

    Ultra 150 voltage regulator Help!!!

    Ok im officialy stumped. Started getting a low voltage warning, checked regulator and it was bad. My box was water damaged so I got a used relay box and changed it out problem went away. Went back out yesterday and started getting the low voltage light again. I pulled a known good one from a buddies ski problem goes away. If I check all 3 regulators they all check good by the manual. But only the one from the buddies ski works. Output from the mag checks good. Anybody got an idea???


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Loose/dirty connections?

  3. #3
    South Atlanta white trash MILF Hunta's Avatar
    Join Date
    Apr 2008
    Posts
    47
    +1
    1
    I got two bad stators one time on my old 93' 750 stand up. Try a new one would be my only guess.

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Went through all the connections everything was fine. Checked the stator output and it was rite by the book. I guess it could have just been bad luck to pop 2. The first one sat soaking in water for awhile and one of the pins to the starter relay corroded off so I had bypassed it. When I got the replacement box it looked new inside.

  5. #5
    BORN TO FISH NOT CATCH
    Join Date
    Oct 2006
    Location
    CENTRAL COAST, CALI
    Posts
    128

    Talking TESTS

    if u are using ohms as the test, throw those away
    obvious u have a meter
    what a bout a DVA?

    easiest and best way to check if bad volt-reg
    turn meter on a/c
    start motor
    put the leads of meter on battery
    if you read more than .8V A/C
    you have a bad regulator

  6. #6
    Skibumtx's Avatar
    Join Date
    Sep 2006
    Location
    Huntsville, AL
    Posts
    105
    I just pulled a good one from my 2001, let me know if you need it.

  7. #7
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Yep I got 3 meters 2 dvm and 1 analog. The digitals give flaky readings when testing some things. I havent tried looking for ac across the battery.

    Quote Originally Posted by 550 OCEAN PRO SLUT View Post
    if u are using ohms as the test, throw those away
    obvious u have a meter
    what a bout a DVA?

    easiest and best way to check if bad volt-reg
    turn meter on a/c
    start motor
    put the leads of meter on battery
    if you read more than .8V A/C
    you have a bad regulator

  8. #8
    BORN TO FISH NOT CATCH
    Join Date
    Oct 2006
    Location
    CENTRAL COAST, CALI
    Posts
    128
    U need a DVA to test voltage from the charging coil

  9. #9
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Both my digital meters will do that one is a fluke 79 the other is a fluke 87. The charging coil output was within spec but I am thinking about changing the stator out just to eliminate it.

  10. #10
    BORN TO FISH NOT CATCH
    Join Date
    Oct 2006
    Location
    CENTRAL COAST, CALI
    Posts
    128
    U do not have a DVA
    u have a DVM

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 150 Voltage Regulator/Rectifier For Sale
    By big_c in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-26-2012, 09:50 PM
  2. Ultra 150 tach install help
    By stang4u2nv in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 10-28-2010, 12:43 PM
  3. Voltage Regulator help plz!!!
    By Danee in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-27-2010, 08:50 PM
  4. Ultra 150 pump removal help
    By kaboom3757 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 07-06-2010, 08:37 PM
  5. ultra 150 handiling ??? please help
    By racer28 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-25-2008, 09:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •