Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317

    just installed GH box.....need help!

    i just installed GH box and i don't know where this water hose is going to....(see pictures)....small hose from J pipe. should i just get a pisser and connect this water hose or just plug it in and thats it. ?


  2. #2
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317

    pictures

    pictures....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1407.JPG 
Views:	31 
Size:	1.37 MB 
ID:	71219   Click image for larger version. 

Name:	IMG_1408.JPG 
Views:	32 
Size:	1.61 MB 
ID:	71220   Click image for larger version. 

Name:	IMG_1406.JPG 
Views:	31 
Size:	1.23 MB 
ID:	71221   Click image for larger version. 

Name:	IMG_1401.JPG 
Views:	29 
Size:	1.66 MB 
ID:	71222   Click image for larger version. 

Name:	IMG_1404.JPG 
Views:	39 
Size:	1.37 MB 
ID:	71223  

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Some people put a bolt in it to plug it and then clamp it. A few people feel that method is a mistake. The right way would be to order the pisser fitting from 4tecperformance.com.

  4. #4
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    I purchased one of these for that line,

    http://www.4-tecperformance.com/inde...roducts_id=800

    Some people just block it off.

  5. #5
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317

    picture

    the water pipe...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1413.JPG 
Views:	30 
Size:	1.04 MB 
ID:	71224   Click image for larger version. 

Name:	IMG_1415.JPG 
Views:	33 
Size:	1.40 MB 
ID:	71225  

  6. #6
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317
    Quote Originally Posted by JFizzleJR View Post
    Some people put a bolt in it to plug it and then clamp it. A few people feel that method is a mistake. The right way would be to order the pisser fitting from 4tecperformance.com.
    just to plug it in would be easer but i would think i'll get too much water in the GH box....or dos it matter ? plug in or pisser ? is it a same resalt ?

  7. #7
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    I think I remember someone saying it's not a good idea to drill into the GH box.

  8. #8
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317
    ....and i'd like to say THANKS to SCOTTY for the fastest shipping ....the box is brand new and the shipping was very fast.

    THANK SCOTTY !

  9. #9
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    I took mine and ran it up under the engine to the two vents in the right front area. I used the one that went to the battery. I just got a simple fitting at the hardware store and installed it in place of the battery vent. Then I attached the hose to it. Looks cool w/ water sparying out of it when you ride two

  10. #10

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    I think that's the high-point vent for the j-pipe. It makes sure all the air is purged out of the j-pipe so you don't overheat the dry metal.

    Mike

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help Re-Installing Front Electrical Box in 1996 XP
    By ande1066 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-03-2015, 09:19 PM
  2. Replies: 10
    Last Post: 06-14-2014, 10:07 PM
  3. Mods installed this week, need help tuning
    By geowelsh in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-30-2011, 08:35 PM
  4. Installing RXP engine, had accident need help?
    By lawracing in forum Conversion PWC Performance Skis
    Replies: 51
    Last Post: 02-18-2009, 02:34 AM
  5. Replies: 10
    Last Post: 01-11-2009, 10:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •