Results 1 to 7 of 7
  1. #1
    CHICKA WAH WAH bren's Avatar
    Join Date
    Sep 2007
    Location
    Cairns, Australia
    Posts
    595

    oil pump snapped

    Hey guys

    66v engine nipped up, pulled plugs......dry...ok, oil flow problem....

    pulled down and turned engine with oil leads off carbs....no flow...

    pulled down further, took air intake off......oil pump has snapped clean off front of engine, but spins freely????

    is this weird or should I stay off the crack pipe???


  2. #2
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    hi bren ..

    any damage other than the oil pump other than nip
    Last edited by Hydrotherapy; 05-07-2008 at 04:01 AM.

  3. #3
    CHICKA WAH WAH bren's Avatar
    Join Date
    Sep 2007
    Location
    Cairns, Australia
    Posts
    595
    not too much, no1 nip up, so slight I should be right with 1200 g wet and dry, will pull the pistons and replace anyway, going to sell the craft so want to sell, and sleep at night

    got a set of pro x ready to go

    happened on the race track and was coming around last bouy 30 feet from my pit area so just glided over and left it there, no trying to run it back to shore

  4. #4
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    very lucky indeed

    you going to swap her to pre-mix or source another pump..

  5. #5
    CHICKA WAH WAH bren's Avatar
    Join Date
    Sep 2007
    Location
    Cairns, Australia
    Posts
    595
    dont know, I'm selling her as a stock racer / cruiser so probably should replace the oil pump and keep her user friendly for the next owner.

    I just gotta sort it out before june 3 as my new bo dupreist / farthing toy gets here and I might lose all sense of urgency when that baby arrives

  6. #6
    that is weird! any chance the balancer bolt backed out?

  7. #7
    WE DONT DIAL 911 RDH's Avatar
    Join Date
    Jan 2007
    Location
    LAKE TRAVIS
    Posts
    1,862
    i hope your flywheel is still ok....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oil pump shaft snapped
    By jasonze in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-20-2015, 05:53 AM
  2. Oil Filter Cap? Good Oil Pump, Mine Sucks!
    By Haislip in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-27-2006, 01:19 PM
  3. Question? Oil pump block off.
    By great lakes gpr 1200 in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 03-26-2006, 01:54 PM
  4. Missing Oil Pump on 06 models
    By bic1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-05-2006, 03:15 PM
  5. will a generic marine oil pump suffice to change my RXP'oil?
    By theantiRXP in forum Sea Doo How To & FAQs
    Replies: 2
    Last Post: 06-25-2005, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •