Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2007
    Location
    Michigan
    Posts
    33

    Question Cavitation vs slipped clutch feeling

    2002 FX 140 Yamaha -----Yesterday while riding very slow I ran into a shallow area of silt and sand in the Intercostal wateway, immediately after getting clear of that spot, I attempted to accelerate and noted what I would call a cavitation or something like a slipped clutch as if it were a automobile. I immediately loaded the FX 140 on the trailer. What possibly did I do and if it continues what is the fix.


  2. #2
    have you looked to see if anything is stuck near ur impellor?

  3. #3
    It's not the destination, it's the journey!! Rip'nTear SHO's Avatar
    Join Date
    Apr 2008
    Location
    Ft. Lauderdale
    Posts
    4,573
    Quote Originally Posted by boat582 View Post
    2002 FX 140 Yamaha -----Yesterday while riding very slow I ran into a shallow area of silt and sand in the Intercostal wateway, immediately after getting clear of that spot, I attempted to accelerate and noted what I would call a cavitation or something like a slipped clutch as if it were a automobile. I immediately loaded the FX 140 on the trailer. What possibly did I do and if it continues what is the fix.
    Did u flush the ski out after u put it on the trailer........great time to check the intake grate/pump tunnel from the bottom and then check inside the nozzle/jet pump from the rear. Ive not run mine into sand yet (gotten real close) but ive had to pick all kinds of vegetation out (ususally lillypads) that got sucked up at a not-much used boat ramp i went to. Do the visual inspection for anything obvious....after that...if the sand is really wedged up into the pump and ur still ahving problems.....im not sure what u should......guys....suggestions?

  4. #4

    Join Date
    Jul 2007
    Location
    Michigan
    Posts
    33

    Question CavitationVSslipped clutch

    Yes I have taken a water hose and cleaned out the inpellor tunnel both from the front and real, all is clean. I start up the FX140 and all sounds normal while on the trailer, but yet to put it back in the water and check it under pressure. could there be any problem between the engine and drive shaft.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Will this cause cavitation or slipping feeling
    By Stockish800hx in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 07-22-2013, 11:58 PM
  2. Is this cavitation what I am feeling(newbie asks...)
    By Jean-Paul in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 05-12-2010, 05:22 PM
  3. does cavitiation feel like a slipping clutch ?
    By davidw in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-14-2008, 05:10 PM
  4. Symptoms of slipping clutch??
    By The Bandit in forum 4-Tec Performance
    Replies: 30
    Last Post: 06-04-2007, 05:48 PM
  5. kawa RSC drive vs RXP clutch
    By mrracing in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-26-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •