Results 1 to 7 of 7
  1. #1
    Yuji's Avatar
    Join Date
    May 2005
    Location
    Prince Albert Saskatchewan, Canada
    Posts
    289

    Installing SS wear ring?

    I removed my old delrin ring with the freezer method with no problem but I'm having trouble getting the SS ring to slide into the pump. I put both the SS ring and the pump in the freezer before trying to install it...is that correct?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    The freezer trick only works with the delrin wear ring.

    You need to put a wood block across the SS wear ring and tap it in with a hammer evenly.

  3. #3
    Yuji's Avatar
    Join Date
    May 2005
    Location
    Prince Albert Saskatchewan, Canada
    Posts
    289
    Okay...thx Jerry

    Thats what I was doing but I didn't want to force it and find out I buggered it up

  4. #4
    You could put the ring in the freezer and the pump in the oven set at 100 degrees. I would think that would give you 3 to 4 thousandths to play with.

  5. #5
    Yuji's Avatar
    Join Date
    May 2005
    Location
    Prince Albert Saskatchewan, Canada
    Posts
    289
    I pondered that thought...not 100* but at least let it warm up to room temp and freeze the ss ring but impatientce got the best of me

    HAMMER TIME lol

  6. #6
    somefun's Avatar
    Join Date
    May 2006
    Location
    Orange CT
    Posts
    252
    Yuji I tapped mine in gently and it was a pain in the azz but it went in

  7. #7
    Yuji's Avatar
    Join Date
    May 2005
    Location
    Prince Albert Saskatchewan, Canada
    Posts
    289
    This one was a tight fit and I can't imagine what it would take to get it out I used a rubber mallet and 2x4...probably should have used a hammer but was too chicken$h!t I would damage the ring or pump housing. Yer right...pain in the A$$

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SS wear ring installed but IMPELLER touches side
    By 03mustardrockets in forum 4-Tec Performance
    Replies: 22
    Last Post: 08-20-2009, 02:27 PM
  2. Installed stage 1 kit and SS wear ring. Break-in??
    By iceman1998 in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-28-2009, 08:21 PM
  3. SS wear ring install problems
    By aha in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-08-2008, 08:27 PM
  4. Install on SS Wear Ring
    By sr71bb in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-23-2006, 05:27 PM
  5. Skat Trak SS wear ring/double bearing pump mod loss of rpms
    By Enufpwr in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-29-2005, 08:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •