Results 1 to 10 of 10

Thread: Riva IC Install

  1. #1
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11

    Riva IC Install

    Anyone else have a hard time when they install their Riva IC? I spent 3 hours last night getting mine installed becasue the metal pipes that connect to the intake and supercharger would not seat properly. I had to un-strap the IC slide it back get everything lined up and then re-strap it all in. Talk about a pain! I am actually sore today from the install!


  2. #2
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by aha View Post
    Anyone else have a hard time when they install their Riva IC? I spent 3 hours last night getting mine installed becasue the metal pipes that connect to the intake and supercharger would not seat properly. I had to un-strap the IC slide it back get everything lined up and then re-strap it all in. Talk about a pain! I am actually sore today from the install!
    Yep, they are a PITA but you learn every time you work with it!! Once in they come back out and in pretty easily. I had to take my XS in and out several times until I got all the hoses like I wanted them. Well worth the effort, though!!

  3. #3
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    The first time install with the Riva IC can be a challange. I found that I had the best luck installing the IC mounted to the bracket and adjusting the IC pipes to the best fit. It is much easier the second time.





    Quote Originally Posted by aha View Post
    Anyone else have a hard time when they install their Riva IC? I spent 3 hours last night getting mine installed becasue the metal pipes that connect to the intake and supercharger would not seat properly. I had to un-strap the IC slide it back get everything lined up and then re-strap it all in. Talk about a pain! I am actually sore today from the install!

  4. #4
    The First Time I Tryed To Install The Riva Cooler I Had Extra Troubles, Because I Am Running The Stock Exhaust. If You Did It In 3 Hours Than You Had A Good Install. I Spent About 3, 3-4 Hour Nights With My Install. Although I Had Alot Of Extra Time In Getting The Stock Exhaust Hose To Work, And It Took Me Along Time To Decide Where To Put The Strainer.
    Worth The Time And Effort, Because I Think That I Could Do It In No Time Now!!!

  5. #5
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Well its good to hear that 3 hours we not to long comparably I found that the IC was sitting to far forward on the bracket and this made it difficult to line up the pipes. I have no idea how anyone could ever install the IC while its strapped to the bracket as the exit pipe is 1/2 way under the footwell. Suffice to say I am very happy with the install as the pipes are all lined up perfectly so airflow should be very good.

  6. #6
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    I have my IC front edge mounted flush to the front edge of the bracket. I was not sure how you were able to get those straps secured with it in the ski, those things are a real pain.

  7. #7
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Yeah I had mine flush mounted too and it was sitting to far forward. I moved it back about 1/2 an inch and everything fit together perfectly.

    For removing the straps what I did was unhook them and leave them attached via the inlet/outlet water fittings. Made my adjustments got it all lined up and installed the air outlet fitting. Then I grabbed one S hook and pulled on it really hard until I could hook it. Did the same thing a 2nd time and it was all set. I think thats why my arms are sore becasue it took alot of muscle to pull them rubber straps.

  8. #8
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    Thanks for the tip on the straps, I will try that if I have to pull it out sometime.

  9. #9
    mine's a pain every time it goes back in right now its out again

  10. #10
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Anytime Dave!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva IC install in a GTX SC...
    By Pale Rider in forum 4-Tec Performance
    Replies: 38
    Last Post: 09-08-2007, 08:12 PM
  2. Anyone have the RR IC install instructions?
    By rx4pain in forum Sea Doo How To & FAQs
    Replies: 8
    Last Post: 07-18-2007, 10:45 AM
  3. Heads-up for '05 IC installers
    By 05Limited in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-14-2006, 02:12 PM
  4. Questions about the IC install.
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-04-2005, 08:04 AM
  5. '05 RXT/GTX RR IC install question... O-ring?
    By 05Limited in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-03-2005, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •