Results 1 to 10 of 10
  1. #1

    Dealer...Dealer...Dealer

    Has has anybody out there had a problem with their Ultra after dealer did the normal warranty mods..ie...water bock off plate..plugs...throttle...etc..

    I have 2 boats '07 taken to the dealer for these repairs and both bots run 3-4 miles slower top end and just a lower boost feeling throughout the rpm range...

    Both boats went in at different times for service...when the 1st ski(70hrs.) came back it started harder taking 2-3 attemots to start and the idle hunted around for several minutes with a 100rpm spread..never did this before..also when riding togrther I could just walk away from this ski mid range and top end..never could before..

    Now boat 2 (40hrs.) which ran great with no problems...has the same crap going on. after its visit to the dealer..harder starts...idle varies 100rpm...loss of power...S/C sounds different..only turns 7650 on the top..I have retorqued the plugs and checked the gap per kawi specs which when returned to me had ZERO torque on them...I know the head is aluminum...and cracked insulators were a problem..maybe the dealer installed them hot and after they cooled they were loose I dunno....anyhow I removed the block off plate from the front as I think kman or Dubz1 suggested to increase fresh air charge..but no help..I see that the dealer was suposed to fog the S/C for 5 seconds with a Kawi fogger...move the hoses to the port side..and install the Block off plate..

    The dealer did change the oil on a previous visit with no problems.but it is above the cold mark with the boat level on the trailer....I'm not trying to point fingers at the dealer for all this stuff but it sure seems strange?

    I cannot figure it out..with the VAST knowledge on this board maybe someone has an idea?

    BTW....there are some really great posts with excellent info....when someone comes up with a perfect combo for reliable increased power for offshore riding..(low end-mid range) I'll do it... untill then I was perfectly happy with the stock performance offshore if I can just get it back!


  2. #2
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    I just read all that and am not sure what you want. Did you bring up your concerns with your dealer?

  3. #3

    Dealer

    Quote Originally Posted by earthshaker View Post
    I just read all that and am not sure what you want. Did you bring up your concerns with your dealer?
    Dealer wants $100hr to water test the boats...I was just searching for some ideas on a similar problem since I have not turned any wrenchs on these skis yet and see that the board has been there done that with most of these performance problems..maybe the new plugs are bad? I have no clue at this point ...

  4. #4
    04gtxsc's Avatar
    Join Date
    Mar 2006
    Location
    Kansas
    Posts
    3,090
    +1
    197
    Not a 250 expert but have you checked the oil level when it is hot?
    John

  5. #5
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    I would think if it goes to the dealer with out issues and comes out with issus they should help resolve and depending on cause they should cover the cost in most cases, especially during the warranty period, I know my dealer whilst not being right into ski's at least has this service motto, and they have redone work at thier cost after a) over filing the oil and b) leaving the bolt loose on the idler pulley, they are human and not perfect like us.....he he.......I think they called it customer service in the old days.....
    Last edited by JET250; 05-08-2008 at 07:22 PM. Reason: ;-]

  6. #6

    Fogging the super charger

    I wonder if you spray just a bit too much of that fogger in the S/C if it would cause a problem in the BOV or the relief valve..possibly in the throttle body or map sensor?

  7. #7
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    first through the s/c then i/c it would have to be a lot of oil, surely they arent dumb

  8. #8
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Over filling the oil will drop RPMs and if they way over filled it then the intercooler is probably gunked up.............

  9. #9

    Thanks

    good ideas

  10. #10
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    The author of this thread decided to create a new one and leave this one hanging - you can find the rest of it here:

    http://greenhulk.net/forums/showthread.php?t=57310

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How about a Dealer Section
    By Sunfunzoom in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 04-23-2006, 08:57 AM
  2. SEADOO DEALER IN LAS VEGAS
    By skypeter in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-04-2005, 03:13 PM
  3. dealer test ride
    By rxp546 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-26-2005, 10:02 PM
  4. Am I a victum of a Crappy dealer or was it the heat?
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-31-2005, 11:27 AM
  5. THE DEALERS OUT THE DOOR PRICE OF 2005 RXP...
    By GSXER2 in forum Sea Doo Open Discussion
    Replies: 34
    Last Post: 05-29-2005, 11:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •