Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2006
    Location
    Iowa
    Posts
    1,028
    +1
    2

    Anyone else seen this? with carbs



    See the fuel/oily line behind the clear diaphram.

    Don't remember ever seeing this on any of the carbs ive opened up.

    Why do ya suppose it got like that?

    Apparently excess fuel/oil in the bottom end someway.


  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Was the pulse line the avenue for the oil? Engine logged w/ fuel/oil once upon a time?

  3. #3

    Join Date
    Aug 2006
    Location
    Iowa
    Posts
    1,028
    +1
    2
    Pulse line had to have been the route.

    Everything else is sealed up well. All new carb parts last summer, and probably 10 hrs on complete engine rebuild.

    Good compression, jetting has been pretty close, no water intake.

  4. #4
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Is the pump mounted low,that can cause it.

  5. #5

    Join Date
    Aug 2006
    Location
    Iowa
    Posts
    1,028
    +1
    2
    I do fog the engine quite a bit.

    The fluid is mostly red in color. (fuel and oil are both red)

  6. #6
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    His pumps are in the carbs.

    Where are the pulse lines tapped?

  7. #7

    Join Date
    Aug 2006
    Location
    Iowa
    Posts
    1,028
    +1
    2
    Quote Originally Posted by Keddano View Post
    Is the pump mounted low,that can cause it.

    The pumps are in the stock location on the carbs.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 07-05-2010, 03:44 PM
  2. Replies: 1
    Last Post: 08-31-2009, 12:33 PM
  3. Anyone else seen this?
    By Gregg in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 12-05-2007, 04:32 PM
  4. Anyone else get this in the mail??
    By Gforce in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 03-16-2006, 07:39 PM
  5. Anyone else notice this on their RXP?
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-30-2005, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •