Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11

    Impeller install problems...

    Hey everyone, I am home now and am trying to install my skat trak 15/19 impeller in my pump but it does not seem to fit. I have the SS wear ring in and the impeller should will not go in. It seems to be a bit to big. Anyone got any ideas? I had it in the freezer all day but that did not help. I used a heat gun and torch to heat up my pump but again that did not help. I am stuck. BTW my old stock impeller drops in fine.

    Thanks!


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by aha View Post
    Hey everyone, I am home now and am trying to install my skat trak 15/19 impeller in my pump but it does not seem to fit. I have the SS wear ring in and the impeller should will not go in. It seems to be a bit to big. Anyone got any ideas? I had it in the freezer all day but that did not help. I used a heat gun and torch to heat up my pump but again that did not help. I am stuck. BTW my old stock impeller drops in fine.

    Thanks!
    Is it a right out of the box prop or has it been pitched. That is the only thing i can think of that would make it not fit. Maybe the experts will chime in.

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    How long have you had the wear ring? The reason I ask is that over time the they can build up corrosion between the aluminum pump and stainless wear ring causing it to close in on the prop. You may not have noticed this with your old prop because the stainless ring has worn it down.

  4. #4
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    new prop and wear ring that has been pitched by nils. I was thinking about the pitching that could cause the problem. It goes in backwords... Nils added 2mm to the trailing edge. Would that small of a bend make the prop not fit anymore?

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by aha View Post
    new prop and wear ring that has been pitched by nils. I was thinking about the pitching that could cause the problem. It goes in backwords... Nils added 2mm to the trailing edge. Would that small of a bend make the prop not fit anymore?
    I have noticed that when i put pitch into prop that it can make the prop tight and rub ring. When i take pitch out of prop it does not seem to affect it much with rubbing.

    On my T-X prop i had to file down some of the outside trailering edge to not have it rubbing prop when I put 2 mm into prop.

    I have heard that 3 blades can need to be shaped up when pitching to make fit ring more so than 4 blades.

    I am no expert so only giving you my experience.
    Last edited by skoepp; 05-08-2008 at 10:40 PM.

  6. #6
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    thanks skoepp... i really am trying to avoid bending the prop back down... i have a dremmel... lol. Anyone else with any ideas?

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by skoepp View Post
    Is it a right out of the box prop or has it been pitched. That is the only thing i can think of that would make it not fit. Maybe the experts will chime in.
    BINGO!!!

    the OD of the blades on the trailing edge have to be filed down a bit.

  8. #8
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    will do Jerry... guess its time to break out the dremmel.

    Thanks everyone!

  9. #9
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by aha View Post
    will do Jerry... guess its time to break out the dremmel.

    Thanks everyone!
    Whoa... Be careful! You don't need to take too much off. I use a file & give it a few hits from the middle of the blade to the end..

  10. #10
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Yup! Don't use the dremel! Use a hand file and sweep around the outside edges and trial fit quite often ... a dremel takes off material way too fast, it only takes a minimal amount of careful work with a hand file.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Impeller install bizarre problem.
    By 88650sx in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 03-13-2012, 09:39 PM
  2. Upgrading clutch on an 06 after impeller install
    By excess in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-16-2006, 10:26 AM
  3. Rotex Racing ECU instalation problem
    By 4-techscharger in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-02-2006, 08:48 AM
  4. New Depth Gauge Transducer/Program Installation Problem
    By STEAMBOAT in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-01-2005, 12:52 PM
  5. Supercharger Impeller Install
    By Teflon in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2005, 06:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •