Page 1 of 57 1 2 3 11 51 ... LastLast
Results 1 to 10 of 562
  1. #1
    wreckmaster's Avatar
    Join Date
    Apr 2008
    Location
    Vancouver,Canada
    Posts
    285

    11ft jetboat with 93sl750motor

    Little project I've been working on for awhile original motor some type of 2cylinder dual exhaust that was in pieces and destroyed Berkly minijet still in it but is a discontinued model no parts or anything available and missing the original intake grate which was a very important piece that i recreated as best i could..had to move the seat forward a bit and cut thru the wall to squeeze the motor in but what a dream to work on compared to in the old hull.Mabye one day i can get a faster motor,but they are hard to find around here.i will try putting up pics
    Last edited by wreckmaster; 05-09-2008 at 04:26 PM.


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Would be great to see some pictures.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Wreckmaster had some trouble posting the photos, so he sent them to me.

    It looks like an engine conversion of an existing Sport-Jet boat, so the jet pump and impeller section may not be Polaris.

    What brand and age of Sport-Jet is this?
    What motor was in there originally?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	boat show+ 014.JPG 
Views:	268 
Size:	2.16 MB 
ID:	72052   Click image for larger version. 

Name:	boat show+ 016.JPG 
Views:	360 
Size:	2.31 MB 
ID:	72053   Click image for larger version. 

Name:	boat show+ 031.JPG 
Views:	656 
Size:	1.39 MB 
ID:	72054  
    Last edited by K447; 05-09-2008 at 06:14 PM.

  4. #4
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Looks like it was running lean! Thats a cool little project though.

  5. #5
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Quote Originally Posted by starflight View Post
    Looks like it was running lean!
    Thats likely what caused your piston melt down.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Good eye star. No wash on them other 2 pistons at all. Lean and lean....

  7. #7
    wreckmaster's Avatar
    Join Date
    Apr 2008
    Location
    Vancouver,Canada
    Posts
    285
    Quote Originally Posted by K447 View Post
    Wreckmaster had some trouble posting the photos, so he sent them to me.

    It looks like an engine conversion of an existing Sport-Jet boat, so the jet pump and impeller section may not be Polaris.

    What brand and age of Sport-Jet is this?
    What motor was in there originally?
    The jet is a Berkley mini model6JA(my first born to anyone who can provide parts)Precision Propeller just finished restoring the impeller since there are no longer parts avalible.I have no clue as to year or make the original motor was trashed,it was a 2 cylinder with a exotic dual exhaust but like the boat no name or squat.I spent 1 and a half years looking for a shop that could fix what was left of the motor but with no way to identify it ,probably discontinued like the jet anyway it was hopless.

  8. #8
    wreckmaster's Avatar
    Join Date
    Apr 2008
    Location
    Vancouver,Canada
    Posts
    285
    Quote Originally Posted by starflight View Post
    Looks like it was running lean! Thats a cool little project though.
    i only realized recently there doesnt seem to be any linkage on the oil pump and i think it might be m.i.a..i think the BOOK mentions somthing about no oil linkage before 95,either way i have removed the pump altogether and fashoned a piece of stainless to cover.

  9. #9
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Quote Originally Posted by wreckmaster View Post
    i only realized recently there doesnt seem to be any linkage on the oil pump and i think it might be m.i.a..i think the BOOK mentions somthing about no oil linkage before 95,either way i have removed the pump altogether and fashoned a piece of stainless to cover.
    With that said, I assume you were running premix oil and gas.
    Adjusting the carbs would be needed to keep from running a lean fuel/air mixture. A lean f/a mixture will burn pistons.
    You also need to check the things xlint89 mentioned in the other thread.
    The single outlet pump should be upgraded, as well as ensuring that the return line restrictor is installed in your setup.

  10. #10
    wreckmaster's Avatar
    Join Date
    Apr 2008
    Location
    Vancouver,Canada
    Posts
    285
    Quote Originally Posted by starflight View Post
    With that said, I assume you were running premix oil and gas.
    Adjusting the carbs would be needed to keep from running a lean fuel/air mixture. A lean f/a mixture will burn pistons.
    You also need to check the things xlint89 mentioned in the other thread.
    The single outlet pump should be upgraded, as well as ensuring that the return line restrictor is installed in your setup.
    actually i wasnt mixing the fuel,i originally kept the oil reservoir and i thought it was at least functioning though when i first start it up the smoke is horrendous till you get going then you dont notice it.after the meltdown we noticed the missing linkage maybe it goes full on if the linkage is not hooked up which might explain the smokeshow.Im not 100%positive there is any linkage for the pump on a 93,thats why now i took the oil system out and i will mix.I have to get someone to do the carbs for me at least until i figure it out.i will phone the local Polaris dealer and see if that better fuel pump can be ordered.Your input is greatly appreciated!

Page 1 of 57 1 2 3 11 51 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for yamaha xr1800 jetboat hull with papers
    By redlinepower in forum Yamaha Projects & Build Threads
    Replies: 2
    Last Post: 03-02-2012, 11:35 PM
  2. What not to do with your RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 60
    Last Post: 01-14-2010, 10:20 PM
  3. Any Jetboat with 2.5 deg pump wedge...?
    By Jeepster in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 02-02-2008, 08:32 PM
  4. What are you guys doing with stock parts off your ski?????
    By Jrsrxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-30-2005, 05:57 AM
  5. Towing the RXP with another boat??
    By Gforce in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-03-2005, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •