Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    2006 RXP for sale
    Join Date
    May 2007
    Posts
    36

    2006 rxp not working

    My 2006 rxp cranked up fine while i flushed it out after riding, the next morning it doesnt respond at all when i put the key on, no guages no beep nothing. the previous day it said 12v low. i replaced the battery and checked it with a voltage guage. all the fuses have been replaced also. if you have any idea what it could be let me know thanks.


  2. #2
    LOOKING HYNES's Avatar
    Join Date
    Apr 2007
    Location
    Brooklyn, MD
    Posts
    740
    Its a seadont go get a kawi no more problems...JK

  3. #3
    I hate things that don't work! SearayEX12's Avatar
    Join Date
    Aug 2006
    Location
    Alexandria Bay, NY
    Posts
    526
    Quote Originally Posted by HYNES View Post
    Its a seadont go get a kawi no more problems...JK
    That helps alot. Lol

  4. #4
    2006 RXP for sale
    Join Date
    May 2007
    Posts
    36
    Quote Originally Posted by SearayEX12 View Post
    That helps alot. Lol

    indeed it does.

  5. #5
    Their Have Been A Few Problems With The Kawi's.

  6. #6
    Quote Originally Posted by gnatsum743 View Post
    Their Have Been A Few Problems With The Kawi's.
    A FEW? ......YOU THINK? ......LOL!

  7. #7
    Quote Originally Posted by HYNES View Post
    Its a seadont go get a kawi no more problems...JK

    if he did that he would be slow!

  8. #8
    MyGreenGumby's Avatar
    Join Date
    May 2007
    Location
    West islip, NY / Portsmouth, RI
    Posts
    230
    Bad rectifier?? - The key on the post doesnt beep beep?

  9. #9

    Join Date
    Aug 2007
    Location
    Rotterdam,NY & Moneta, VA
    Posts
    1,617
    +1
    1
    check your battery connections. a cable might have vibrated lose or you might have some corrosion on the terminals.

  10. #10
    2006 RXP for sale
    Join Date
    May 2007
    Posts
    36
    Quote Originally Posted by MyGreenGumby View Post
    Bad rectifier?? - The key on the post doesnt beep beep?
    what is the rectifier? and no it doesnt beep at all

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 rxp fuel pump runs gauge wont work
    By pjsc823 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-21-2009, 09:21 PM
  2. new RXP-X speedometer not working on my machine
    By davidescu_radu in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-06-2008, 04:36 PM
  3. VTS not working on 2004 RXP
    By Tatorsalad in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-15-2008, 02:52 AM
  4. Compass not working 2006 GTX Ltd
    By RebelYelle in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-08-2006, 12:39 PM
  5. 2005 RXP Trim not working?
    By idizzy in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-27-2006, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •