Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1

    Join Date
    Feb 2007
    Location
    Tampa, FL
    Posts
    186

    SHO broken 0.00 hrs

    well my maiden voyage was back to the dealer the gps was probably close to 80mph... the ski wont start, starter spins but wont engage. i made sure the battery was fully charged but nothing. im so damn pissed off right now thank god i tried to start it before leavin the house( which i learned long time ago). A friend tried to talk me out of gettin an SHO and now im wondering what else will happen with this ski. The dealer has been great so far, i called and the guy remembered me from saturday. He said we're open til 6pm but i have a tech here til 7pm that can look at it. when i got there he came right out and checked it over but nothing. So now im here pissed off as my 0.00 hr never seen water ski is at the dealer...


  2. #2
    Piraya33's Avatar
    Join Date
    Apr 2008
    Location
    Ocala, FL
    Posts
    68
    Damn, that really sucks! Hopefully it's just a quick fix and you'll realize you made a great choice going with the SHO. Good luck!

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by Piraya33 View Post
    Damn, that really sucks! Hopefully it's just a quick fix and you'll realize you made a great choice going with the SHO. Good luck!
    +1

  4. #4
    Does it crank over?

  5. #5

    Join Date
    Feb 2007
    Location
    Tampa, FL
    Posts
    186
    the starter was spinning but wouldnt engage

  6. #6
    Do you mean it turns over but it won't start?

  7. #7
    Are you giving it gas when you are pressing the start button?

  8. #8

    Join Date
    Feb 2007
    Location
    Tampa, FL
    Posts
    186
    no the starter spins but doesnt engage the flywheel. so the motor doesnt spin

  9. #9
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    bendix prob??

  10. #10
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,363
    +1
    55
    wow that sucks, hey but look at it this way it would have been worse if it happen in the water, then you'd be real pissed

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Supercharger Belt is broken after 4 HR....
    By RXP-X 2011 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 58
    Last Post: 03-23-2014, 11:01 AM
  2. FS - Parts Sho/Fzr exhaust 4 hrs old
    By crashhard in forum Yamaha Classifieds
    Replies: 28
    Last Post: 10-26-2013, 09:53 PM
  3. Riva BOV hose broken @ 35-40 hrs.
    By dso8950 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 08-05-2012, 09:07 PM
  4. FS R&D Free Flow Exhaust for SHO/FZR $ 50.00
    By coby45 in forum Yamaha Classifieds
    Replies: 8
    Last Post: 11-08-2010, 10:06 PM
  5. FS R&D Air Intake intake For the SHO FZR. $ 80.00
    By coby45 in forum Yamaha Classifieds
    Replies: 3
    Last Post: 11-07-2010, 05:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •