Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    maxing out at 7850 rpms

    I have just changed the starter relay, took it for a spin, and it ran rough. I put new plugs in it. (old ones very oily), and it runs fast and smooth, but wont go over 7850 rpms and tops out at 63 on dreamometer (usually hits 70). There are no codes coming up at set x's 5. Any Ideas?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Low RPM's can be attributed to several causes

    Over filled oil
    worn wear ring
    boost leak

  3. #3

  4. #4

    Join Date
    Nov 2006
    Location
    NC
    Posts
    361
    Quote Originally Posted by Green Hulk View Post
    Low RPM's can be attributed to several causes

    Over filled oil
    worn wear ring
    boost leak

    Jerry , how will a worn wear ring cause low rpm's ?
    Have not run into that one before , thought it would cause cavatation and higher rpm's?

  5. #5
    seadoor's Avatar
    Join Date
    Nov 2006
    Location
    Puerto Rico
    Posts
    538
    s/c clutch washers failure

  6. #6
    Quote Originally Posted by seadoor View Post
    s/c clutch washers failure
    If that were the case he wouldn't be turning near 7850 RPM...more like 6500 RPM.

  7. #7
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    822
    Mine tops out at 7800, but maxes out the speedometer at 69 with ease and keeps accelarating. I heard they are to hit 8100 RPM, but not sure since mine was moded when I bough it. I just sent in my SC to Jerry to have the washes swapped to the metal ones. If it was slipping at all this should help.

    How many hours does your ski have? Has any other work been done to it? I know on mine the washers were swapped at about 60 hours then the SC was rebuilt at about 110 hours on mine. Maybe your washers are starting to slip or it is just warmer outside.
    Last edited by Gus13letter; 05-13-2008 at 08:24 PM.

  8. #8
    seadoor's Avatar
    Join Date
    Nov 2006
    Location
    Puerto Rico
    Posts
    538
    i will check the s/c believe me that its your problen

  9. #9
    Thanks guys, my rxt has 63.5 hours, and it feels smooth. I looked at a lot of old posts that state 7800 to 8000 is normal, so maybe its me. When I changed the plugs, the #1 plug is under that plastic piece, so I took out the four screws and pushed it back out of the way. Maybe something came loose when I did that cause there are a few hoses connected there. If it wasnt for the dreamometer reading 7 lower than normal, I would have thought there was a problem.

  10. #10
    I would NOT have thought there was a problem.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. seadoo rxp max out at 6500 rpm with WOT
    By rxpsquad in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-20-2012, 10:21 AM
  2. Polaris 2 stroke keeps bogging out at 4000 rpm
    By DIGGYFLA in forum Polaris PWC Performance
    Replies: 5
    Last Post: 08-29-2009, 11:28 PM
  3. 2000 Genesis max out at 40mph
    By bxtr97 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 08-18-2009, 06:31 AM
  4. 98 GSXL tops out at 6300 RPMs ...on a good day
    By d0n in forum 2-Stroke Performance
    Replies: 12
    Last Post: 08-11-2008, 05:29 PM
  5. 99 GTX Ltd Cutting out at high RPM
    By Picturemn2 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-28-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •