Results 1 to 9 of 9

Thread: 03 gtx sc

  1. #1

    Join Date
    Jun 2006
    Location
    Hidden Valley Lake, CA
    Posts
    28

    03 gtx sc

    Hey guys,
    I have just installed a stage I and my rpm are 7100. top speed of 60 can anyone help? I also put in a new plastic pump and bearings. runs great just no top speed.


  2. #2
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    how is the acceleration out of the hole?

  3. #3

    Join Date
    Jun 2006
    Location
    Hidden Valley Lake, CA
    Posts
    28

    thanks

    I has great hole shot it runs great faster than before just no top end of 65

  4. #4
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    when you say plastic pump do you mean plastic wear ring, also what were the RPM`s before you installed the stage 1

  5. #5

    Join Date
    Jun 2006
    Location
    Hidden Valley Lake, CA
    Posts
    28

    thanks

    It has a new pump housing and wear ring and impeller. I was turning 7600 rpms consistently. Pete

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    I have a 03 GTX SC also I know what you are going through it took me 30 hours a new pump and 3 SC clutches before mine ran like it should but I now have 60 hours of trouble free riding and 65 MPH all day long now.

    I would start with the clutch after you double check the pump installation, have you removed or blocked up the OPAS if not that may be the problem, have you cahnged the oil recently it may be to full

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    i thought clutch as well shhr.... but i asked how his holeshot was bc that woulda been a good giveaway if his clutch was slipping or gone. I'm inclined to think his prop it just pitch badly.... no lag out of the hole, no cavitation, RPMs are higher than they would be IF the clutch was toasted.. i'm leaning words prop, but clutch is never 100% out of the question, lol ... but good points of checking OPAS and oil level as well.

  8. #8

    Join Date
    Apr 2005
    Location
    Elysian Fields,Tx
    Posts
    358
    The early '03 Gtx Sc did have the plastic pump housing. I know mine did and when I put the stage 1 kit on it it split the pump next to the water intake hole.Luckily Seadoo replaced it with the aluminum one under warranty.Hope this is not what happened to yours but if you do have the plastic housing you need to get rid of it it won't hold up to any mods and flexes like crazy even without mods.With the new pump and the stage one with the Skat-trak 3 blade prop I was doing 67 plus. It would easily outrun my RXT when it was stock.

  9. #9
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    +1
    1
    Damn i could only get a best of about 63-64mph out of my 03. I didn't have a lot done, just free flow exhaust, nopas, and rideplate holes filled. I would have been fairly happy with 65mph. Hopefully an intake and rxt prop will show some gains IF i ever get it together.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My 03 GTX SC should see 70mph by spring!
    By 01xdime in forum 4-Tec Performance
    Replies: 12
    Last Post: 12-10-2005, 02:01 PM
  2. 03 GTX SC opinions wanted........
    By 01xdime in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-13-2005, 11:56 PM
  3. Why did my 03 GTX SC beat an 04 RXP?
    By 01xdime in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-10-2005, 06:36 PM
  4. What's the good pump setup for a stock 03 GTX-SC?
    By Jarrett in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-15-2005, 05:17 AM
  5. A few pics of my almost finished 03 GTX sc
    By two2curupt in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-20-2005, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •