Results 1 to 7 of 7
  1. #1
    kman's Avatar
    Join Date
    Aug 2007
    Location
    Labrador
    Posts
    193

    Loss of RPM/cavitation when turning left!?

    I just got the ski back together after finding missing drain bolt in intake manifold which is why my RPM's were only 7200-7300 and also had pump done by IMPROS.
    Now my RPM's are up to 7800-7850. Problem now is at WOT the RPM stays constant when going straight or turning right but when I turn left the RPM's drop to 7300 and I hear a slight noise which sounds like cavitation.
    I checked the steering and when turning left or right the throttle cable is fine. I also made sure I did a good job with the silicone when putting the pump back together. Everything is smooth with no holes or excess silicone. I also checked the pump clearance prior to install and it looks like IMPROS did a great job. When I had the intake off I also installed the shoe stuffers from R&D. This was installed properly and should be OK as well.

    Any suggestions??


  2. #2
    tomgtv's Avatar
    Join Date
    May 2006
    Location
    Weston Florida (Ft. Lauderdale)
    Posts
    1,744
    +1
    1

    check air intake

    I read a post where somebody's air intake wasn't tight. It was moving and sucking up to the hull, thus lowering rpm's and performance. When they backed off throttle it went back to normal. At least it sounds like something that could happen. I haven't even looked at mine to see if it is possible!

  3. #3
    benjahw benjahw's Avatar
    Join Date
    Jan 2008
    Location
    Naples, Fl
    Posts
    467
    +1
    30
    yep that was my post.... but this sounds different. turning left natuarally lowers rpm and turning right heightens it w/ this ski. so that part is somewhat normal. but if your hearing a sound, i dont know.. is it coming from the pump or motor?? probably the pump. 7300 is less rpm than i get when turning left. normal rpm for me as 7800. turning left gives me about 7500-7600. turning right gies about 7950. make sure nothing is loose underneath. grate, plate, nozzle. maybe your steering needs calibrating too.

  4. #4
    kman's Avatar
    Join Date
    Aug 2007
    Location
    Labrador
    Posts
    193
    No, it's not the air intake as I already checked this - Thanks for the suggestion though.

    As far as the noise it's only a very slight noise that sounds like the beginnings of cavitation. I also noticed that the RPM's went up slightly when turning right. If this is happening somewhat on yours then maybe this is normal. Any other people experiencing a similar situation? I'll double check the RPM's when I go out again as maybe it didn't drop as low as 7300 when turning left.

  5. #5
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    I see as much as a 120 -140 RPM rise with a slight pull to the right when going straight line............

  6. #6
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    I wonder if the steering cable is pulling on the throttle cable, I think I saw in the SM that they run together on the right side, mmmm must read more. love the SM.

  7. #7
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    I believe it related as to how the jet wash comes out of the nozzle...............the impeller rotates to the right when sitting on the ski.................

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo Sportster 155hp 4-tec loss of power when turning left
    By Dlh1228 in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 09-01-2016, 09:34 AM
  2. RPMs arent the same when turning left compared to right
    By axelderhund in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 07-22-2009, 12:57 AM
  3. Loss of rpms in turn.
    By cfnnslsq in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 05-13-2008, 11:57 PM
  4. Skat Trak SS wear ring/double bearing pump mod loss of rpms
    By Enufpwr in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-29-2005, 08:11 PM
  5. Jerry - Loss of rpm - loss of speed
    By RXPDAVID in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-13-2005, 03:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •