Results 1 to 4 of 4

Thread: Pump stator

  1. #1

    Pump stator

    Chasing a vibration that I doubt is motor related! so I pulled the pump and found cavitation burns on the impeller no biggie but I did find 2 of the 6 veins had a quarter$ size chunk missing! would that cause an in the water only vibration at idle and just above? seems to clear up above 20! I bought this ski non running so I don't have a bench mark to go by accept for my other one that runs way smoother both have new motors Thanks Z


  2. #2
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    I wouldn't think so, but I guess anything is possible. . . I had a really bad stator but didn't notice anything like that before or after changing it. Bad bearings or an out of balance prop are more likely culprits. and the 1200 engine does shake like a crack whore at low speed.

  3. #3
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    maybe even a bent driveshaft?

  4. #4
    Thanks! I didn't think so but with only two of six missing chunks I wasn't sure! I'm getting a new prop and looking for a stator but will vee block the driveshaft . Z

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 6 vane jet pump stator
    By bedbug357 in forum Polaris PWC Performance
    Replies: 29
    Last Post: 06-09-2008, 09:18 AM
  2. Pump stators--how do they work
    By Bruins in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-01-2007, 10:20 AM
  3. '05 pump stator for sale anyone??
    By GP1300R powerhouse in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-31-2007, 02:41 PM
  4. Skat pump stator cracked
    By bainer1290 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-01-2007, 08:22 PM
  5. Silicone between pump stator and extension ???
    By Bilgewiper in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 04-16-2007, 11:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •