Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33
  1. #1
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11

    Cavitation Part II

    Hi everyone, in my quest to determine why I have severe cavitation out of the hole I pulled my pump out and apart. I found the metal ring that screws into the back of the prop stuck on the driveshaft. I also found water in the pump cone area. I took pics of the prop to wear ring gap. It looks pretty tight to me. The prop/ring have 1 hour on them. I also took pics of the prop pitch. All 3 blades are exactly the same pitch. I took a pic from both the end of the prop and 1 inch from the rear of the blade.



    Could any of this help contribute to the cavitation?

    Thanks,
    Ahmed
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mini-IMG_4986.JPG 
Views:	40 
Size:	195.6 KB 
ID:	73130   Click image for larger version. 

Name:	mini-IMG_4987.JPG 
Views:	37 
Size:	190.6 KB 
ID:	73131   Click image for larger version. 

Name:	mini-IMG_4971.JPG 
Views:	32 
Size:	118.9 KB 
ID:	73132   Click image for larger version. 

Name:	mini-IMG_4972.JPG 
Views:	32 
Size:	104.0 KB 
ID:	73133   Click image for larger version. 

Name:	mini-IMG_4973.JPG 
Views:	28 
Size:	164.9 KB 
ID:	73134   Click image for larger version. 

Name:	mini-IMG_4974.JPG 
Views:	31 
Size:	109.3 KB 
ID:	73135  



  2. #2
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    More pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mini-IMG_4975.JPG 
Views:	30 
Size:	142.8 KB 
ID:	73136   Click image for larger version. 

Name:	mini-IMG_4977.JPG 
Views:	25 
Size:	107.4 KB 
ID:	73137   Click image for larger version. 

Name:	mini-IMG_4979.JPG 
Views:	40 
Size:	117.3 KB 
ID:	73138   Click image for larger version. 

Name:	mini-IMG_4981.JPG 
Views:	28 
Size:	100.0 KB 
ID:	73139   Click image for larger version. 

Name:	mini-IMG_4982.JPG 
Views:	46 
Size:	108.4 KB 
ID:	73140   Click image for larger version. 

Name:	mini-IMG_4988.JPG 
Views:	29 
Size:	258.8 KB 
ID:	73141  


  3. #3
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Last of the pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mini-IMG_4991.JPG 
Views:	41 
Size:	131.1 KB 
ID:	73142   Click image for larger version. 

Name:	mini-IMG_4995.JPG 
Views:	38 
Size:	136.2 KB 
ID:	73143   Click image for larger version. 

Name:	mini-IMG_5002.JPG 
Views:	29 
Size:	154.2 KB 
ID:	73144  

  4. #4
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    It's hard for me to tell for sure in the pics but it looks like to me the prop has too much clearance with the wear ring. The prop should actually touch the wear ring ever so slightly as you spin it by hand. This much clearance would cause cavitation.

  5. #5
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    Change the big rubber seal that may cure it.It did on mine

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by lafjax View Post
    It's hard for me to tell for sure in the pics but it looks like to me the prop has too much clearance with the wear ring. The prop should actually touch the wear ring ever so slightly as you spin it by hand. This much clearance would cause cavitation.
    Measure the clearance with a feeler guage and let us know what the clearance is... Ron

  7. #7
    Quote Originally Posted by King_Of_Fun View Post
    Measure the clearance with a feeler guage and let us know what the clearance is... Ron

  8. #8
    aha, your pump veins shows trauma. anything happened in the past?

  9. #9
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,067
    +1
    790
    Guys IMO his Pump and clearence look good. Not bad at all.

    Pump shoe, Carbon Ring, or even the Rubber seal on the pump?

    I would start with the Rubber Seal on the pump. I have found a lot of problems with them just flipping of just a bit and causeing cavitation.


    OH yea, just another note. DID you bend your own prop? I have found that some props I bend have a little wave in them from me bending them and from Dave at impross he said this cause a problem in flow and can cause cavitation aswell..

    /
    Last edited by Water4fire; 05-16-2008 at 07:49 AM.

  10. #10

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    I can see the SS ring has worn away that prop pretty good; you running with a solid front motor mount?

    Also, your nose cone needs a new O-ring in the pump to keep the water out.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cavitation Part 3
    By aha in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-24-2008, 09:25 PM
  2. Thru the hull hole part II
    By bruinsrme in forum 4-Tec Performance
    Replies: 23
    Last Post: 11-25-2007, 09:33 PM
  3. RXP stage II H Temp light coming on PART II
    By MIARider in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-16-2007, 01:39 AM
  4. My New RXT runs like Poop part II
    By 2006 RXT in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-14-2007, 11:30 AM
  5. slt 780 dies part II
    By rbridges in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-12-2007, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •