Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1

    Whats wrong with my 03 gtx?

    OK here it goes. When I first got the ski last augest it did like
    55-58 mph @ 69-7200 rpm. Than I got a metal pump, new wear ring, R&D intake, and solas 12-20 ss prop. Now it does like 48-50 mph @ 65-6800 rpm.
    I thought it was kinda slow before I did the mods some of you guys told me to check if the sc was slipping. When I put a socket on the end and turn it turned the whole engine over and it does have metal washers.
    What do you guys think I should do besides sell it and get a rxp-x


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by FL03GTX View Post
    OK here it goes. When I first got the ski last augest it did like
    55-58 mph @ 69-7200 rpm. Than I got a metal pump, new wear ring, R&D intake, and solas 12-20 ss prop. Now it does like 48-50 mph @ 65-6800 rpm.
    I thought it was kinda slow before I did the mods some of you guys told me to check if the sc was slipping. When I put a socket on the end and turn it turned the whole engine over and it does have metal washers.
    What do you guys think I should do besides sell it and get a rxp-x
    It sounds like you are way over-propped. Go back to the stock impeller and see what your rpms are. You should be turning 7550-7600 rpms. Also, check your oil with the engine warm and level (idle for 30 sec, engine off for 30 sec, then check the oil). You might also fill the ride plate holes,,, Ron

  3. #3
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    build a 4" front air intake to get your rpm's up.
    but i think your sc is slipping or you have a boost leak.
    your rpm was low when you were stock.

  4. #4
    I know the rpm was low to start. I dont see how it could be slipping when i turn the sc wheel it trys to turn the whole engine over. Plus in august when i got the ski, I talked to the mechanic at the dealer where i got the ski and he told me he just rebuilt it along with new prop & wear ring, oil change and plugs. I checked for boost leaks with a spray bottle of soapy water. I couldent see any bubbles. I do have a mech boost gauge it only show like 3-4 lbs, thats all it ever showed.

  5. #5

    Join Date
    Jun 2007
    Location
    Madill,ok
    Posts
    13
    dont trust the dealer. they will lie to you, check every thing again, your self,

  6. #6
    do i have to remove the sc to check slippage?

  7. #7
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    i think if you put a vice grip on the drive shaft, to lock the engine, and then test the slip moment on the SC, it would be accurate.
    does anyone agree with this?
    what is the correct torque spec for the SC anyways??

  8. #8
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by gamble View Post
    dont trust the dealer. they will lie to you, check every thing again, your self,
    Have you checked the compression? There was a ski on PPG's site acting the same - it had a bad piston... Ron

  9. #9
    going from front of the ski to back 140 psi 130 psi 125 psi & was done
    @ wot.

  10. #10
    skipSC's Avatar
    Join Date
    Feb 2006
    Location
    Stuart, Fl.
    Posts
    1,445
    +1
    171
    That's 15lb spread, not great. RPM should be around 7650 stock and 7850 level 1 and your S/C doesn't have washers, it's metal and just take the intake off the S/C and put a socket/torque wrench- check it in a c/w direction ( no need to hold shaft with vice grips, if you do, the clutch welded itself) and look for 50-100inlb slip moment. Good luck.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. whats wrong with my piston?
    By kastay29 in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 06-06-2011, 08:31 PM
  2. Whats wrong with my SKI!!??
    By coseeighty1 in forum 4-Tec Performance
    Replies: 18
    Last Post: 06-24-2010, 11:58 PM
  3. HELP with my 03 GTX
    By jcancel in forum Southeast
    Replies: 4
    Last Post: 08-25-2009, 09:20 AM
  4. Whats wrong with my ski?
    By zxiripper in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-26-2009, 07:06 PM
  5. What's wrong with my 15f
    By Toby in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 08-02-2007, 10:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •