Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Question Need help with msx140 compression

    Hi guys,this is my first post.I have an 03 msx 140 with 125hours on it and i did a compression test.center cyl 80,the other two 120.i did the test right.the jet ski runs fine with a top speed of 57-58.what do you think?just go ahead and take out the head?oh forgot to say that last week i was at lake Pyramid and test it out with a yamaha fx ho and we had same acceleration and top speed. any tips would be helpfull,thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by msx140 View Post
    Hi guys,this is my first post.
    I have an 03 MSX 140 with 125 hours on it and I did a compression test.

    center cyl 80,the other two 120.
    i did the test right. the jet ski runs fine with a top speed of 57-58.
    what do you think? just go ahead and take out the head?
    oh forgot to say that last week i was at Lake Pyramid and test it out with a Yamaha fx ho and we had same acceleration and top speed.
    any tips would be helpful, thanks
    Welcome to the Hulk!

    Low compression on the CENTER cylinder, yet you still have good speed and power?
    Was speed measured with a GPS, or the digital display?

    What RPM are you turning on the water at Wide Open Throttle?

    Have you downloaded the MSX 140 Service Manual?
    Last edited by K447; 05-18-2008 at 11:57 AM.

  3. #3
    speed was on the digital display but i can't remember rpm.i have the manual also.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I'd also like to say WELCOME to the Green Hulk Forums!!
    57-58 on speedo, I think that's about 54-55 maybe even slower on the GPS.
    You should probably inspect the cylinder before you do any more riding.

  5. #5

    msx 140 cylinder

    so guys i found the problem.what caused that deep groove?also what should be the position of the piston rings (i found that the gaps were aligned...i thought they should be on opposite sides..)
    thanks again
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0231.jpg 
Views:	64 
Size:	115.6 KB 
ID:	73565   Click image for larger version. 

Name:	IMG_0234.jpg 
Views:	66 
Size:	115.2 KB 
ID:	73566  

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Perhaps the piston ring locating pin(s) came loose?

  7. #7
    you are right.i just so the piston.so now what?i need a new cylinder?

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Contact Randy at Watcon he will have what you need

  9. #9
    ok thanks alot ,i hope i don't need a cylinder.

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    You need to have your cylinder repaired. It can be filled and re-nik'd.
    I'd measure the fuel pressure and make sure it's within spec. I'd consider sending in the injectors and control unit to have them calibrated and make sure the injectors are spraying correctly.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NEED HELP with 2003 MSX140
    By pb0000 in forum MSX/Matrix
    Replies: 12
    Last Post: 08-07-2010, 08:47 PM
  2. Need help with low compression
    By jasonstang88 in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-31-2010, 10:06 PM
  3. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM
  4. Need help with a Sony Handycam
    By kenshin89 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-27-2006, 06:42 PM
  5. Need help with 04 S.C. rebuild
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-10-2006, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •