Results 1 to 5 of 5
  1. #1

    Season off to a bad start

    Hello everyone, I am a new guy to the forum. I have an 05 rxt that I just put back into the water this season after being winterized by the dealer. I have brought it to be winterized every winter since buying the machine in 05. I have 40 hours on it. It ran fine last season, but yesturday on the water i was only gettin about 6500 rpm. I was thinking mabe bad plugs and gas but after getting it home i read on here to check the supercharger impeller, and unfortunatly it spins. I guess my real question is could there be engine damage from the ceramics? I was on the water for no more than 15 min because i knew something was wrong.

    I also pulled the plugs at first to check those and they had oil on them, I am not sure if thats a good thing either.

    Thanks for the help.

  2. #2
    My new toys at work bruinsrme's Avatar
    Join Date
    Jul 2007
    Worcester MA
    I would venture to say the ceramics are shot.
    I am not familiar enough withwhat needs to be done to clean that up. I am sure others here are.

  3. #3

  4. #4
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Visalia, Ca

  5. #5
    Thanks for the information. I am just confused as to whether or not there is a chance it is just slipping and has not completely let go yet? I contacted my dealer and they said that they did 6 or 7 last summer. They said they replace it with the metal washers and rebuild kit from sea doo. They also suggested pulling the motor to make sure there are no particles of ceramic if need be.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 05-06-2011, 07:53 AM
  2. 1200 genesis backfiring bad starting
    By mark1 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-29-2010, 05:47 PM
    By jclc43837 in forum Mudbug Nationals PWC.Life Rally
    Replies: 15
    Last Post: 06-11-2010, 10:25 PM
  4. Oil block off....good or bad???
    By ktmrider08 in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 08-21-2008, 09:54 AM
  5. First start of the season gone bad!
    By raiderteen in forum Yamaha Old School Skis
    Replies: 46
    Last Post: 03-03-2008, 10:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts