Results 1 to 9 of 9
  1. #1
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637

    Bearing gone bad

    Had my bearing / seals go bad on my ski today. Almost drown my ski in the middle of the lake! Thank God I installed the bilge pump 2 weeks ago. Anywho, I need a new one fast. Where can I score one? Do they come as an assembly, or do I have to put one together?

    Pic #45 on page 167 of the manual

    95 SLT 750


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Are the seals bad?? Are there groves on the drive shaft??

  3. #3
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637
    Havn't removed the DS yet to determine grooves. I am assuming the seals are bad. It is leaking after all. I also figured, If you replace part of it, you might as well replace it all.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Try John Zigler for a used one, but that may take time.

    Ebay, or post a WTB.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by jonjonwells View Post
    Had my bearing / seals go bad on my ski today. Almost drown my ski in the middle of the lake! Thank God I installed the bilge pump 2 weeks ago. Anywho, I need a new one fast. Where can I score one? Do they come as an assembly, or do I have to put one together?

    Pic #45 on page 167 of the manual

    95 SLT 750
    Page 167 of which manual?
    Have you downloaded the 1992-1998 Service Manual?

    Are you sure it is the through hull bearing/seal assembly (item 9) that is leaking, and NOT the plastic through hull fitting (item 12) behind it?
    Page 6.35 in the 1992-1998 Service Manual.



    There have been a few of these that have come loose, and leak water into the hull.
    Last edited by K447; 05-20-2008 at 12:24 AM.

  6. #6
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637
    Quote Originally Posted by K447 View Post
    Page 167 of which manual?
    Have you downloaded the 1992-1998 Service Manual?

    Are you sure it is the through hull bearing/seal assembly (item 9) that is leaking, and NOT the plastic through hull fitting (item 12) behind it?
    Page 6.35 in the 1992-1998 Service Manual.



    There have been a few of these that have come loose, and leak water into the hull.

    Yup, coming out the front of the bearing assy.

    Thanks to Randy, I should have a brand new one installed for a weekend of riding.

  7. #7

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    that sucks for your ski to quit on your birthday

  8. #8
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637
    Better on my b-day on a small lake, than the middle of Lake Perry.

  9. #9

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    that woulda diffently sucked , how is that 3rd degree sun burn treating ya ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 carrier bearing gone bad? fx (140)
    By cigarlust in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-30-2014, 02:48 PM
  2. ride plate inserts gone bad
    By Hydrotherapy in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 08-09-2007, 12:07 AM
  3. EFI controler gone BAD??
    By flyboy in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-13-2006, 01:46 AM
  4. statue of liberty trip gone bad!!!
    By mxl16 in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 11-05-2005, 12:26 AM
  5. oil change gone bad
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-31-2005, 07:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •