Results 1 to 4 of 4
  1. #1

    Unhappy rxp07 won't beep

    was testing the ski and first crank didnt start the engine. took out the yard and placed it agian on the post. this time no beep/s. the info guage lits up then turns off except the compass. tried the start button but no response. can anyone pls help? thanks

  2. #2
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Looks Like You Have A Low Voltage Battery Of Loose Battery Terminals. Also Check For Dirty Terminals Too....

  3. #3
    thanks but tested uising battery from another working doo. checked terminals and other connections. no fuse busted. might it be the ecu?

  4. #4
    just tried swapping ecu with gti 155. Its the ecu (

    Sent my ecu to dealer for possible repair. Hope i wont have to buy a new one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gp 1200 r beeping but won't run
    By stealthbomber87 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-27-2012, 09:28 PM
  2. Replies: 0
    Last Post: 08-17-2011, 03:13 PM
  3. lanyard won't connect or beep
    By NPEWILL in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-29-2010, 10:16 PM
  4. 96 xp just beeps and won't won't turn over
    By Tatorsalad in forum 2-Stroke Performance
    Replies: 11
    Last Post: 07-13-2008, 08:27 AM
  5. GTX won't turn off when you pull the key, keeps beeping.
    By FLSUN in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-06-2008, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts