Results 1 to 3 of 3
  1. #1
    Autosport's Avatar
    Join Date
    Feb 2007
    In the Fast lane

    Problems with GPR HO pumps

    After reading the thread bellow, it doesn't give me much confidence in a GPRXP running 85 to 90mph running the HO pump...

    What other options are there to aleviate these problems?
    Is anyone here experiencing this problem?

  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    You can opt for a Seadoo RXP/RXT/GTX LTD. Pump

  3. #3
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Mesa, AZ
    Either his prop is spaced wrong or he is eating rocks. A jetpump is a jetpump. There is no magic.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new guy with problems with fuel pump
    By crazuri2 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 07-24-2008, 07:34 PM
  2. problem with 06' gpr
    By cagpr_rider in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-21-2008, 04:06 PM
  3. found big problem with my GP Pump shoe
    By Mr1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 12-17-2007, 10:39 PM
  4. Any problems with 120 mains on a 1200 GPR?
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-27-2007, 02:10 PM
  5. What ignition for GPR? Weird problem with R-D CDI
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-19-2006, 06:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts