Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Cam chain broke

  1. #1
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356

    Cam chain broke

    suspect at the weekend after a wee race against me mates rxp-x i broke my cam chain ,i came of revs just before and could hear something like a chain rattle at the front of the ski,a few seconds later i lossed power and engine is locked ,
    i see in a search you can get lucky when they break and it just needs a new chain rather than a rebuild is this common or likey to be a rebuild ?just bracing my self

    the good news was i kicked my freinds butt
    Last edited by rior1; 05-20-2008 at 06:28 AM.


  2. #2
    JESUS G's Avatar
    Join Date
    Jun 2007
    Location
    South Florida
    Posts
    566
    +1
    154
    Hi, I had the same probblem this weekend with one of our RXT-X, i will need to replace some valves and the cam chain, but the pistons are ok.

    If you only need to replace the chain you can use a tool from KTM, is the same kind of cain like KTM 4 stroke.

  3. #3
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    Had the same thing happen on my NA 155 GTX. Unless there is something drastically different about the RXP - you have to do a complete tear down to replace. Can you elaborate on the use of the cam chain tool? There isn't much slack to work on the chain and mine did cause some case damage. I think you almost would have to open and look.
    Last edited by thompsdw; 05-20-2008 at 06:50 AM.

  4. #4
    Yamaha tow boat RIDEALLDAY's Avatar
    Join Date
    Feb 2006
    Location
    Texas
    Posts
    1,447
    When my camchain broke it damaged a few valves AND the head, it had to go to a machinist for repair.
    My chain broke after a dealer ceramic washer replacment. Lasted 15 minutes then boom!

  5. #5
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356
    finally got round to pulling the rocker cover today and the chain looks ok ...relief for a second then i thought it must be a flywheel bolt sheered can these do alot of damage to engine when they fail ?

    still waiting to hear from the tax man to see how much money i got left to fix ski up


  6. #6
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    something tells me u are going to wish it was the chain......

  7. #7
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356
    always with the negative waves ...you gotta think more positive ,
    ill give it a wash and polish and she"ll be as good as new


    did you hear that god ,iam talking to you

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Maybe you lost a supercharger bearing and it locked up. Try removing your supercharger.

  9. #9
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    He said from the front, but I was thinking, try taking the pump out if the sc doesn't do it.

  10. #10
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,339
    +1
    121
    The noise I heard when my SC bearings went sounded like it was coming from the front. Pop the SC outlet hose off and inspect for gray dust.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB: New Head Gasket & new cam chain for 04 RXP
    By Seadooracer9 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-06-2014, 06:42 PM
  2. 02 GTX NA cam chain broken
    By dtfly in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-21-2009, 09:08 PM
  3. Timing chain broke.....help
    By BlackHawk in forum 4-Tec Performance
    Replies: 91
    Last Post: 07-03-2008, 04:12 PM
  4. cam chain issues
    By ajrunke in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-20-2008, 02:18 PM
  5. My RXP cam chain failure head pics
    By JAG in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-23-2007, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •