Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Need Some Help

  1. #1
    GPR_KID #42 Fabian_1's Avatar
    Join Date
    Sep 2007
    Location
    Cayman Islands
    Posts
    84

    Exclamation Need Some Help

    yeh i want 2 know what to do to take the jetworks work i have a rubber one and a metel one with one do i use and do i put the rubber one in first i don't know send me some pic's that can show me what 2 do thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00216.JPG 
Views:	36 
Size:	308.4 KB 
ID:	74021   Click image for larger version. 

Name:	DSC00217.JPG 
Views:	22 
Size:	287.5 KB 
ID:	74022  


  2. #2
    Greenhulk Grasshopah (DRC) HallPass's Avatar
    Join Date
    Jun 2007
    Location
    Kansas
    Posts
    5,587
    +1
    2
    your gonna use both gaskets for the jetworks mod.

    Just put them both on..

  3. #3
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26
    The metal gasket goes on the waterbox side....

  4. #4
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    I agree the metal goes on the waterbox side. I would not trust that rubber one though it looks distressed a bit.

  5. #5
    GPR_KID #42 Fabian_1's Avatar
    Join Date
    Sep 2007
    Location
    Cayman Islands
    Posts
    84
    ok so wa u sayin is that u need all 2 ok i get that but when u put all 2 them together where does the water go cuz if i put them together it block one side and where i put the hole where the temp senser waz do water come out of that one too r only one??????
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00217.JPG 
Views:	25 
Size:	287.5 KB 
ID:	74065   Click image for larger version. 

Name:	DSC00216.JPG 
Views:	29 
Size:	308.4 KB 
ID:	74066  

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Are you going to run the jetworks valve??? Or is this a stock set-up?


  7. #7
    JKR1300's Avatar
    Join Date
    Jan 2006
    Location
    St Louis & 6mm LotO
    Posts
    497
    +1
    6
    Beerdart - your diagram is wrong. Drain at bottom of stinger goes overboard.
    Inlet at the top gets water from jetworks via the pump

  8. #8
    GPR_KID #42 Fabian_1's Avatar
    Join Date
    Sep 2007
    Location
    Cayman Islands
    Posts
    84

    Question

    wa???????????? u sayin one thing and he sayin a next thing with way then lol

  9. #9
    JKR1300's Avatar
    Join Date
    Jan 2006
    Location
    St Louis & 6mm LotO
    Posts
    497
    +1
    6
    Do a search on jetworks - I believe most people run the lines as I have said - which is per Fercho's original instructions

  10. #10
    GPR_KID #42 Fabian_1's Avatar
    Join Date
    Sep 2007
    Location
    Cayman Islands
    Posts
    84
    ok i see if i can do it this time

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM
  2. need some help
    By Pettee in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-12-2006, 05:44 PM
  3. Need some help ?
    By RXP04 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-20-2006, 04:36 PM
  4. Need some help planning a trip.
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 21
    Last Post: 03-15-2006, 06:58 PM
  5. SeaDoo 3D (need some help)
    By MARKUS in forum 2-Stroke Performance
    Replies: 21
    Last Post: 02-09-2006, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •