Results 1 to 6 of 6
  1. #1

    04 gtx sc just clicks

    Thats all it does when i try to start it. I thought it was the battery took it to advance and they said it was fine. Brought it back home and still nothing. So then I tried jumping it from another ski and did the same thing, i put the lanyard on wait for it to beep and then when i hit the started button i can hear something clicking in the motor. Any ideas would help.....


    thanks
    brenton


  2. #2
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    can you turn the engine over by hand by clamping some vice grips to the shaft( inside the hull) and turning it back and forth??

  3. #3

    Join Date
    Jan 2007
    Location
    So. Calif
    Posts
    21
    Check the solonid.....Mounted on the side of the MPEM. The red device that the positive battery cable is connected to.....

  4. #4
    Quote Originally Posted by RATMAN View Post
    Check the solonid.....Mounted on the side of the MPEM. The red device that the positive battery cable is connected to.....

    He is right check silonoid first with test light.One side is always hot the other side goes hot when you hit the start button.Pull the plugs that will make the motor turn over easy.If it goes hot the start might be bad.


    If that does not do it pull supercharger and pump to see if they are locked up.If they are OK it has to be in the motor.

  5. #5
    Doo'n it on the Lake ... GTXDawg's Avatar
    Join Date
    Mar 2008
    Location
    Middle TN
    Posts
    110
    ... also check main 30A fuses to left of MPEM - just went thru same think w/ my 05! Was a corroded fuse!

  6. #6
    I'm all out of favors!!
    Join Date
    Apr 2008
    Location
    Orlando
    Posts
    48
    Hope the timing chain isn't broke. Most likely the solenoid/relay unless it did it while running, if you can turn the drive shaft (with the spark plugs out) then the pump and engine should be ok, and it could be a bad connection, relay, or starter; If not then I'd pull the pump (jet) and see if it's the pump or the engine. 185's are notorious for blowing up down here....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 GTX sc hesitation...just had jerry rebuild sc?
    By jwyrick in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-11-2009, 03:46 PM
  2. Removing Pump Cone on 04 GTX SC
    By cinciguy in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-26-2006, 04:28 PM
  3. '04 GTX SC electrical problem
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-01-2006, 06:49 PM
  4. What is an 04 GTX SC...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 05-10-2006, 07:45 PM
  5. '04 GTX SC RPM
    By 05Limited in forum 4-Tec Performance
    Replies: 6
    Last Post: 03-18-2006, 09:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •