Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215

    Groco SHATTERED!?

    Came back from a run, was cleaning the ski up, and I noticed my Groco was shattered...Its still solid, but now its got me worried, especially with our group run tomorrow...

    I think I am gonna wrap a layer of fiberglass and resin around it, then order a new one right away...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0141.JPG 
Views:	34 
Size:	63.2 KB 
ID:	74510   Click image for larger version. 

Name:	IMG_0142.JPG 
Views:	32 
Size:	55.2 KB 
ID:	74511   Click image for larger version. 

Name:	IMG_0143.JPG 
Views:	41 
Size:	70.9 KB 
ID:	74512   Click image for larger version. 

Name:	IMG_0144.JPG 
Views:	42 
Size:	60.5 KB 
ID:	74513  


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by Danny View Post
    Came back from a run, was cleaning the ski up, and I noticed my Groco was shattered...Its still solid, but now its got me worried, especially with our group run tomorrow...

    I think I am gonna wrap a layer of fiberglass and resin around it, then order a new one right away...
    Thats weird. How old is it. Maybe the cold weather or something.

  3. #3

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Check for blockages in the ic or preasure in the cooling system.

  4. #4
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by skoepp View Post
    Thats weird. How old is it. Maybe the cold weather or something.

    Year old...Water temp was fine, it survived the Gobble Run last year with upper 30 degree water temps...

  5. #5
    I think we need to lay off the Goble runs! IMO! Unless you are stock it's not a good idea. Was there water in it over the winter? Probably not! Interesting though!

  6. #6
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    It almost looks like it came in contact with gas or brake/carb cleaner... Kinda...

  7. #7
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Antifreeze in the system over the winter...ran it on the hose 3-4 times before putting it in the water today...

    I took the sticker off last year, then used brake cleaner to clean the residue...which made it cloudy...

    I think it was banging off my metal pipes, because there is w witness mark on the pipe where it was rubbing...I know for a fact it was not like this when I put it on this morning...so I am gonna put a layer of fiberglass on it and turn the strainer a little more...

  8. #8
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by Danny View Post
    Antifreeze in the system over the winter...ran it on the hose 3-4 times before putting it in the water today...

    I took the sticker off last year, then used brake cleaner to clean the residue...which made it cloudy...

    I think it was banging off my metal pipes, because there is w witness mark on the pipe where it was rubbing...I know for a fact it was not like this when I put it on this morning...so I am gonna put a layer of fiberglass on it and turn the strainer a little more...
    Well that sucks. Wouldnt figure antifreeze would do anything like that. How old is the strainer?

  9. #9
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Cleaner weakened the plastic and the contact with the pipe caused the cracks is what I would guess. The cracks are on the inside portion of the bowl, correct?

  10. #10
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    I cleaned it last year when I installed it, it ran all summer (even mudbug) with no problems...

    The cracks are internal, can't feel them on the inside or outside....

    I just wrapped got done wrapping a layer of fiberglass, will order a new unit on monday/tuesday...

    It hit my metal piping...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Groco install for Dummies
    By badams7 in forum 4-Tec Performance
    Replies: 13
    Last Post: 02-28-2009, 03:30 AM
  2. Groco intercooler strainer on a Speedster 150
    By VX1 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 04-08-2007, 04:39 PM
  3. Groco water strainers
    By steved in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-23-2007, 03:03 PM
  4. Finally installed my groco filter on my RXT
    By beached log in forum 4-Tec Performance
    Replies: 1
    Last Post: 12-05-2006, 08:09 AM
  5. Groco water strainers now available in the online store!
    By Green Hulk in forum 4-Tec Performance
    Replies: 111
    Last Post: 12-02-2006, 12:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •