Results 1 to 7 of 7
  1. #1
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46

    Question warning light and 12 volt low

    Right, i went out on my ski and almost straight away the red warning light would flash 3 times like every 30 seconds but no message would come up pn the display????? Then after i while i did get the 12 volt low message come up. Now my ski had a new gel battery end of last season which i fully charged before my first trip out (only last sunday) I have checked the battery at idle and it was getting 13.6-8 volts. Mainly i want to know why the red light would flash but no message and what could be wrong to cause the 12 volt low warning. Thanks in advance


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,180
    +1
    98
    When you say "no message comes up" did you try pressing the SET button 5X and see if a fault code comes up?

  3. #3
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    check the fuse for the voltage regulator, mine was in there loose and caused this problem

  4. #4
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    no i didnt do the set button check but i will and where is the fuse? any help thanks.R8

  5. #5
    Doo'n it on the Lake ... GTXDawg's Avatar
    Join Date
    Mar 2008
    Location
    Middle TN
    Posts
    110
    LOL (funny now that it's fixed - wasn't so funny yesterday tho!) - had same problem - just resolved it here ...

    Check these 2 fuses below - the fuses are inside the connectors - when you unclip the plugs you will see the fuses inside of the plugs. Both of mine were badly corroded. Cleaned/replaced them & started right up!



    Now have 14.5V across battery posts - system is charging fine now.

    ... took me 2 days to figure it out tho!

  6. #6
    hey whats up. I have an 06 rxp with the same dam problem. I tried fixing it my self didnt work cant win. So took to dealer and the tech talked to me say there a design problem were we have are white storage tank under the hood the container puts stress on the wires cause them to loose cantact, causing no charge or 12v low he did that and also put some zip ties and no problem since. But last year same problem happen again so i said o great but my battery explosed loosing 2 cells. Check your battery fill plugs my where missing half broken from jumping big waves in the storm and big boats :P


    NO PROBLEMS SINCE THEN THANKS TO GREAT Marine TECH at EXREME MOTORSPORTS in Indian , Hammond

  7. #7

    12v Low problem fuses

    GTX Dawg
    Where did you get the pictures of the 2 fuses? The pictures are still a little hard to see.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 seadoo xp 12 volt low and maint light flashing
    By mikenstella in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-22-2016, 01:18 AM
  2. ERROR - Both 12 volt high and 12 volt low errors plus P0562 code
    By govenatorx in forum 4-Tec Performance
    Replies: 9
    Last Post: 10-04-2013, 07:33 AM
  3. 12 volt low warning at low RPMs on 1999 GTX RFI
    By Britpilot in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-12-2013, 12:22 AM
  4. 12 Volt Low Warning - Need Help
    By Tedcfitz in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-12-2013, 09:05 AM
  5. 12 volt low warning, where is rectifier?
    By gbest in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 07-23-2007, 09:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •