Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843

    My Mods and test results

    Well i finished installing the BOV and Boost gauge today im seeing 12 lbs on the vac side and im unable to make any boost on the trailer .. This will be the real test to see IF the Riva S/C impellar makes any more boost than the stock . I will get reading from the boost gauge for one full day and then i will be installing the riva s/c imp to see the gains as many of you know i gps each mod one by one currently I have the riva cold air kit . stock prop repitched by impros . riva top loader grate and I blocked off the opas and im running the riva BOV currently im seeing 70.6 with 3/4 of a tank on glass conditions and 68.3 in choppy water with very nice acceleration ..it is not the arm ripping acceleration that some companies and even people claim however it is a pretty nice upgrade from stock .. i will be installing the s/c impellar and denso plugs then re testing just for everyones knowledge the biggest gains were seen in the prop nearly 2 mph no gains with blocking off opas not even .1 mph and minimal gains in mph with the riva cold air kit @.5 mph but it all adds up and helps in acceleration ... I weigh 215 lbs and all my tests so far were in real world conditions with at the very least 3/4 of a tank of fuel ....


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    good deal! I'd like to hear how much more boost you see on the gauge with the stock SC Impeller VS. the Riva one.

  3. #3
    mgo7483's Avatar
    Join Date
    May 2005
    Location
    Jacksonville, Florida
    Posts
    176
    Crazed,

    Are you running the Impros "Powertune" pitch on the stock prop or did you ask for a specific pitch?

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    I'll answer for him

    He is running the Impros Powertune with a 12/19.5 pitch on his impellor.

  5. #5
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Jerry - can you answer this one? I got the Solas 14/19 from PPG in their Level 1 kit. Do you know what they repitch these impellers for this kit at?

  6. #6

    Join Date
    Apr 2005
    Location
    Augusta GA
    Posts
    720
    PPG I dont think give out there pitches. When I order my solas the first time out it would only run 7900rpm with some wicked acceleration. On the second pitch it ran 8100-8150 with the same wicked acceleration. No that I have adden the Power filter I should have seen something on top end but the rev limiter wont let it so, PPG has my Solas now repitching it to bring the rpms to 8100 so I hope to see 71 mph on top end. keeping my fingers cross.

  7. #7

    Join Date
    Apr 2005
    Location
    Augusta GA
    Posts
    720
    One mroe quick question??? I am full for them i hope to have my Soals back befor this weekend but if not I might have to slap on the stock and go for it. Did any body out there run there Power filter with the stock impeller ???? How was it ??? and after feeling the acceleration of the solas I know the accelration hsa got to be much poor or is it. i jsut wonder what it would be like.

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    No, PPG doesnt give out their pitches.

    Jr. I originally ran the stock repitched 12/19.5 and got great results. The solas would out accelerate it.

  9. #9
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    Im running the stock imp with the power filter as i prefer top end speed over acceleration anyday ... the stock imp with the repitch and finish from impros is ok ... u will never get the aceleration the solas gives u but u may get a lil more top end with the stock impellar .. i just talked to dave yesterday about my set up and for top speed he still says go with the stock impellar ..

  10. #10
    mgo7483's Avatar
    Join Date
    May 2005
    Location
    Jacksonville, Florida
    Posts
    176
    The reason I ask about the pitch is because I sent my impeller off to Impros back in January for the “Stage 3 Powertune”. All I told Dave was that I wanted to hold 8100 rpm; I did not give him any kind of specific pitch. I picked-up about 1-2 mph from the repitch and I am very happy with it. Dave withholds the powertune pitch just like PPG with their Solas pitch, so I’m not really sure what my current pitch is. Lately, everyone has said that the 12/19.5 on the stock impeller is the one to have. I have a friend that as an RXP and I can pull away from him pretty steady on top end. So, I told him about the 12/19.5 pitch and he sent it to Dave. Now, with the 12/19.5 he has lost at least one mph and I can really walk away from him. So, I don’t know what that’s all about…


    Either way, he got pissed and went out a bought a Solas and sent it to PPG. He just got it back yesterday, so I guess we will what happens. He did call Dave to complain and Dave told him to send the stocker back and he’ll “re” re-pitch it.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MY RXT-X STAGE III Mod & Test Result
    By qatar2000kk in forum 4-Tec Performance
    Replies: 17
    Last Post: 10-04-2008, 03:33 AM
  2. GOLD RXP STAGE III Mod & Test Result
    By qatar2000kk in forum 4-Tec Performance
    Replies: 32
    Last Post: 09-28-2008, 06:36 AM
  3. What are your mod and results
    By Jrsrxp in forum 4-Tec Performance
    Replies: 33
    Last Post: 12-17-2007, 08:20 PM
  4. TEST RESULTS: Jim's FF Plate and Advent CDI
    By MPower in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-01-2007, 08:27 PM
  5. test results from latest mods
    By Bamafanatic in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-21-2006, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •