Results 1 to 9 of 9
  1. #1
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338

    What clamps did you use after rotax thermostat

    Are the oetiker clamps worth trying to get or did you guys just use normal clamps after you cut the original ones off to install the thermostatt???


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Regular stainless hose clamps.

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    ditto... regular SS clamps

  4. #4
    Quote Originally Posted by Shibby1485
    ditto... regular SS clamps
    same here...PR...

  5. #5
    Jet Set Performance's Avatar
    Join Date
    May 2006
    Location
    Cherry Hill, NJ
    Posts
    37
    +1
    1
    Quote Originally Posted by Pale Rider
    Quote Originally Posted by Shibby1485
    ditto... regular SS clamps
    same here...PR...
    Not that you installed the 'stat or anything!! LOL!! Yeah, stainless hose clamps, all the way!!

  6. #6
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    figured it might have been important to run the oetiker clamps since Riva uses new ones but I guess not.

  7. #7
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    oetiker

  8. #8
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    I cant find them anywhere individually only by packs, and it takes 4 different sizes

  9. #9
    Quote Originally Posted by excess
    I cant find them anywhere individually only by packs, and it takes 4 different sizes
    I had a hard time too finding a couple of the Riva sizes.
    I'm going to use worm clamps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2 stroke oil questions..What brand do you use?
    By GeoRXT in forum Yamaha PWC Performance (2-stroke)
    Replies: 54
    Last Post: 08-09-2008, 11:04 AM
  2. What impeller are you using?
    By xlint89 in forum Polaris PWC Performance
    Replies: 35
    Last Post: 10-28-2007, 11:23 AM
  3. What gps do you use?
    By Brett541 in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 06-01-2007, 09:19 AM
  4. What did you use to make a rail for your trailer fuel cans?
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-28-2006, 12:41 PM
  5. OPAS Removed, What sponsons are you using?
    By ramnj in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 04-09-2006, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •