Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: Help guys!

  1. #1
    raiderteen's Avatar
    Join Date
    Nov 2007
    Location
    Marion, Illinois
    Posts
    320
    +1
    5

    Help guys!

    Click image for larger version. 

Name:	jet ski problems 003.JPG 
Views:	24 
Size:	1.13 MB 
ID:	74804

    Click image for larger version. 

Name:	jet ski problems 004.JPG 
Views:	23 
Size:	667.3 KB 
ID:	74805

    Click image for larger version. 

Name:	jet ski problems 005.JPG 
Views:	21 
Size:	679.2 KB 
ID:	74806

    ok about the first one when we put some more grease in it last year it was red now its all brown??? my dad says its cause it got water which would make it wear teh leak is coming from can that second cover come off i have unscrewed it and it wont budge also the second and third pics it is a little spring like thing and we found it by the bilge sump any ideas on wat it is?


  2. #2
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    I am confused as to what you are refering to as the SECOND cover. Do you mean the intermediate housing? You have three bolts undone but there may be another one that you have to feel for underneath. My GP1200 has a sneaky one that you can't see, the Raider may be the same way. Either way, once the intermediate housing is unbolted, it will come off. It may take some prying with screwdrivers or prybars. It would not be a bad idea to get new bearings and seals. Judging from the color of the grease in the pics an excessive amount of water is making its way in, and I am sure the shaft has alot of play in it.

  3. #3
    raiderteen's Avatar
    Join Date
    Nov 2007
    Location
    Marion, Illinois
    Posts
    320
    +1
    5
    well i have takin the cover that has teh grease fiting and the coupler shaft off and then that cover you see in the first picture isnt wanting to come off i have already ordered the seal and o ring that goes behind that cover i highly agree it has to be getting ALOT of water to be makin it that brown when it was blood red in the middle of last summer that might be the problem to all the water that was making it sink last year in the marina

  4. #4
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    It will come off, but it is tough sometimes. You may have better luck if you pull the pump.

  5. #5
    raiderteen's Avatar
    Join Date
    Nov 2007
    Location
    Marion, Illinois
    Posts
    320
    +1
    5
    i really really dont want to do that if i dont have to

  6. #6
    the spring is probably from the damaged seal!

  7. #7
    raiderteen's Avatar
    Join Date
    Nov 2007
    Location
    Marion, Illinois
    Posts
    320
    +1
    5
    y would the seal need a spring i was thinkin it was from the carbs maybe?

  8. #8
    well ur pic sucks but most oil seals have a circular spring that helps seal the shaft

  9. #9
    raiderteen's Avatar
    Join Date
    Nov 2007
    Location
    Marion, Illinois
    Posts
    320
    +1
    5
    i took some pics with that last cover off any idea what we are looking at?
    Click image for larger version. 

Name:	jetski pump repair 003.JPG 
Views:	26 
Size:	785.8 KB 
ID:	75047

    Click image for larger version. 

Name:	jetski pump repair 002.JPG 
Views:	26 
Size:	885.6 KB 
ID:	75048

    Click image for larger version. 

Name:	jetski pump repair 001.JPG 
Views:	25 
Size:	1.15 MB 
ID:	75049
    my dad was wondering if it was normal for there to be oil back there in that area of the shaft he thinks a oil seal has blown
    Last edited by raiderteen; 05-27-2008 at 09:33 PM.

  10. #10
    jdog800's Avatar
    Join Date
    Feb 2007
    Location
    Alexandria L.A.
    Posts
    812
    the seal to keep the water out of the intermediate is in the end of the pump housing. you will have to remove the pump to change this.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Had a scary incident with ski just now, need help guys
    By Shibby1485 in forum 4-Tec Performance
    Replies: 104
    Last Post: 09-22-2007, 09:55 PM
  2. need some help guys...
    By minersny in forum Polaris Open Discussion
    Replies: 6
    Last Post: 03-24-2007, 01:00 PM
  3. 05 Rxp Riva Stage 3 Help Guys!!!
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 15
    Last Post: 03-06-2007, 11:02 PM
  4. XLT1200 help guys?
    By Suthrn in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-20-2006, 08:10 PM
  5. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •