Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    msx 150 limited to 3400 rpms

    I have a 04 msx 150 with 50hrs on it that just started being limited to 3400 rpms today with no check engine light on.It will run fine for a while then it will mess up.I have checked the reverse and the esp switch both are opening and closing.Any suggestions on what to check next


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by sdbillyg View Post
    I have a 04 MSX 150 with 50hrs on it that just started being limited to 3400 rpms today with no check engine light on.
    It will run fine for a while then it will mess up.I have checked the reverse and the esp switch both are opening and closing.
    Any suggestions on what to check next
    Welcome to the Hulk!

    There are a few MSX 150 owners around here.

    Do a search for wastegate on the Green Hulk Polaris forums, as I think there is a problem with the waste gate shaft sticking, and the engine controller then limits power to avoid over-boost.

  3. #3
    How easy should the rod move? I have checked it and it did move every time so far. Thanks for the reply

  4. #4

    Join Date
    Oct 2006
    Location
    Beaver Falls, PA
    Posts
    281
    First What state do you live in? Salt water is the most common effect on the stuck waste gate arm. So if you live in Kansas I'm sure it is not a stuck waste gate.
    Second are there any gauge symtoms that are active on the gauge low fuel, temp indicator blinks? Not the red eye in the center.
    Third if you ride the vessel does it ever stall out?
    Fourth Check for air leaks on the intake track of the engine. In the water with the seat off can you hear an air leak. Check for loose hose clamps on the intake track. And do you see any signs of an exhaust leak with the seat off and the engine running?
    Just a few things to check.

  5. #5
    I live in tn so no salt water. I dont hear any leaks or see anything that looks like a leak. Theres is no warning lights or check engine light on except on start up.It has never stalled out just will not go over 3400 rpms most of the time. Thanks for the reply
    Last edited by sdbillyg; 05-27-2008 at 06:12 PM.

  6. #6

    Join Date
    Oct 2006
    Location
    Beaver Falls, PA
    Posts
    281
    time to do a compression test and a leak down test. sounds like you are running on 1 cylinder

  7. #7
    Looking looking32908's Avatar
    Join Date
    May 2008
    Location
    Palm Bay, Florida
    Posts
    21
    Had that problem last year. I looked for hours for the problem. Rode it with the seat off, and the watse gate was working fine. I also had no lights.

    The problem was the lower clamp on the big short fat hose on the turbo side of the motor. So I was sucking air. Problem fixed.

    Good luck.

  8. #8

    msx 110

    I have 2 msx 110 that I have been working on forever it started out as the guy owns them overfilled them with oil! I cleaned everything clean enough to eat off of changed both mass air sensors and tried no lights runs great but same thing will not go over 3500 rpms. I was told today by a person that has worked on a few of them that the waste gate solnoid is bad! My waste gates move fine! This part number will supposedly fix it 0452313.

  9. #9
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    Quote Originally Posted by jetskigreg View Post
    I have 2 msx 110 that I have been working on forever it started out as the guy owns them overfilled them with oil! I cleaned everything clean enough to eat off of changed both mass air sensors and tried no lights runs great but same thing will not go over 3500 rpms. I was told today by a person that has worked on a few of them that the waste gate solnoid is bad! My waste gates move fine! This part number will supposedly fix it 0452313.
    I replaced my solenoid on my MSX 150, before I learned that my waste gate was 'frozen'. I left the new one on the ski, and have the old one (good), and will part with it, if it can work in the 110. It had just over 100 hours on it....

    My solenoid number is 0451349...maybe Jay can jump in, and tell us if they are compatible!

  10. #10
    found out mine still had warranty left so its at a dealer now.Will post what the problem is if they get it fixed.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 MSX-150 Surges and MAX RPM 5850
    By rcsscraig in forum MSX/Matrix
    Replies: 37
    Last Post: 09-09-2015, 06:53 AM
  2. Replies: 7
    Last Post: 06-28-2012, 08:34 PM
  3. MSX 150 Anyway to test a fuel pressure regulator?
    By freelancenovelist in forum MSX/Matrix
    Replies: 1
    Last Post: 06-14-2009, 08:26 PM
  4. MSX 150 - No CEL Max RPM 6000
    By Beerme in forum MSX/Matrix
    Replies: 6
    Last Post: 05-18-2009, 07:27 PM
  5. polaris msx 150 burning oil limeted rpm help plz
    By ln69bt in forum MSX/Matrix
    Replies: 22
    Last Post: 04-09-2008, 10:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •