Results 1 to 7 of 7
  1. #1

    Join Date
    Mar 2008
    Location
    Palm City, FL
    Posts
    25

    Oil Pressure Switch

    I'm my 04 R12X Turbo I'm getting a flashing oil light if I hit a big wave and the ski goes into limp mod and won't go over 4k rpm's... I have heard this is a high pressure oil switch trigger??... well with that said there are 2 pressure switchs on the ski... Low and High... Which one is the high one??

    SKU: 35500-HW1-671
    SWITCH ASSY., OIL PRESSURE
    It's #16 on the picture pointing to the side of the ski

    SKU: 37240-PHM-003
    SWITCH ASSY., OIL PRESSURE
    It's #17 on the picture pointing to the front of the ski



  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    its the one that has 2 leads going to it instead of one lead. #16


    Shawn

  3. #3

    Join Date
    Mar 2008
    Location
    Palm City, FL
    Posts
    25
    Thanks Shawn! Do you feel replacing this sensor will fix my problem??


    Quote Originally Posted by NitroShark View Post
    its the one that has 2 leads going to it instead of one lead. #16


    Shawn

  4. #4
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    Most sensor problems are caused by corrosion.

    Check that first. By not posting your location in your profile I don't know were you live, but salt water is 10 fold a problem with connections. Silicone grease should be used.

    Shawn

  5. #5

    Join Date
    Mar 2008
    Location
    Palm City, FL
    Posts
    25
    Can I try this: Go out on the water... duplicate the problem with the high pressure sensor unhooked and if it doesn't cut the motor then that's the problem??

  6. #6
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    no you can't, That's why there are 2 wires one to ground and one to the ECU, it will error out. clean the conections out/ replace the sparkplugs and retry it.

    Shawn

  7. #7

    Join Date
    Apr 2007
    Location
    Birmingham ,AL
    Posts
    88
    +1
    3
    Hey Buddy. Did you find out what caused the problem and what fixed it. I would be very interested to find out. I have a similar problem , Thanks man
    Quote Originally Posted by Scooter View Post
    I'm my 04 R12X Turbo I'm getting a flashing oil light if I hit a big wave and the ski goes into limp mod and won't go over 4k rpm's... I have heard this is a high pressure oil switch trigger??... well with that said there are 2 pressure switchs on the ski... Low and High... Which one is the high one??

    SKU: 35500-HW1-671
    SWITCH ASSY., OIL PRESSURE
    It's #16 on the picture pointing to the side of the ski

    SKU: 37240-PHM-003
    SWITCH ASSY., OIL PRESSURE
    It's #17 on the picture pointing to the front of the ski


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil pressure switch problem
    By Squirl in forum Honda How To & FAQs
    Replies: 24
    Last Post: 07-15-2012, 09:06 PM
  2. oil pressure switch
    By ed kramar in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-31-2012, 07:41 PM
  3. Oil Pressure Switch Thread Size ?
    By PWCGUY in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-14-2010, 09:52 AM
  4. '04 oil pressure switch failure
    By RXP'in in MI in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-22-2007, 10:06 PM
  5. Kawi 12F Oil Pressure Switch Issue
    By kauferlie in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 11-03-2006, 05:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •