Results 1 to 4 of 4
  1. #1

    Speedometer stuck on zero: VX sport

    My new waverunner, 17 hours, all of a sudden it seems to have stopped measuring the speed. It reads zero, no matter what speed we were in the water. I don't see anything in the manual, the service manual or in Google.

    I'm guessing that it depends on a water intake somewhere but would like guidance on where to look at what could be blocking it. thanx, sam


  2. #2
    check the paddle wheel at the back bottom of ski for a weed

  3. #3

    #21


  4. #4
    Thanks, that has to be it. It turns out I have tiny metal shavings. It appears that the paddle wheel has magnetic properties and I could not get them all off. Not sure what I must have run over, but I did not see any evidence of wear in the area, sam

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oil level rising up on 2014 vx sport
    By caterpillar in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-21-2015, 04:32 PM
  2. Pls help this newbie out ref: 1st service on 2014 Yamaha VX Sport
    By SamVX in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 06-23-2014, 09:27 PM
  3. Using VX Deluxe Wiring harness on regular VX or sport
    By speeedracer27 in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 08-06-2013, 08:50 PM
  4. 2011 with 500hrs - whats the life on VX Sport engine
    By harbrown in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-17-2012, 09:46 AM
  5. Installing Reverse on VX Sport
    By TheEngineer in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 03-15-2010, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •