Results 1 to 2 of 2
  1. #1

    slxt 1050 missing

    have problem with ski missing when under heavy load.
    works fine up to 1/2 to 3/4 throttle, but go over this and she misses again.
    have replaced a damaged flywheel ( magnet was damaged) when main shaft bearings let go...before last rebuild.
    any suggestions on where to look first?


  2. #2
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by leeanroy View Post
    have problem with ski missing when under heavy load.
    works fine up to 1/2 to 3/4 throttle, but go over this and she misses again.
    have replaced a damaged flywheel ( magnet was damaged) when main shaft bearings let go...before last rebuild.
    any suggestions on where to look first?
    WELCOME TO THE HULK
    I think(witch doesnt always work ) they have an updated stator and cdi for that motor -not shure,cant remeber what the sysptoms were
    i am a fuji(blue motor) guy,you have a red domestic,i bet in 12 hours you will have more info on this than you can handle j/k sorta
    try the search for some info now
    the red people(hahahhaah) will chime in soon
    enjoy and have fun
    mattman

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 stlx 1050 running rough. Feels like its missing.
    By FloridaEdd in forum Polaris Open Discussion
    Replies: 20
    Last Post: 07-03-2014, 05:14 PM
  2. Missing Oil Pump on 06 models
    By bic1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-05-2006, 03:15 PM
  3. In case any of you missed this....butt-Rocket/funny
    By BertInTexas in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 11-07-2005, 05:28 PM
  4. Missing piece on steering nozzle ?!?
    By Kinchyle in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-05-2005, 01:03 AM
  5. notice anything missing!!??
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-17-2005, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •