Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2003 GTX 4Tec SC Oil Light prob.

    Hi,
    im new to the site but i have a hopefully small prob.i have a 03 gtx 4tec sc. when i first put my ski in the water if i go faster then like 15mph or half thottle the oil light comes up on the screen and start to beep and the ski gose into like a limp mode. it will do this for like 10-15min. and then stop and run perfect.i was told oil level might be low but it not.then i was told change the front oil sensor and i did. but it still dose it. just woundering if anyone know whats going on.


  2. #2
    Has the oil pressure separator sensor been replaced? If not you have a oil pump problem, but it sound like you have a sensor problem, have the oil pressure sensore replaced and the oil pressure separator sensor replaced and it should fix your problem!!, dont forget to get the updated oil cap for your ski if you have not done that already!!

  3. #3
    thanks,
    im not sure what sensor is the one in the front, but that is the one i justs replaced. and i dont know if the replacement cap has been done i just got the ski. where can i get the replacement oil cap at my local dealer i guess. i dont think it is the oil pump i hope but the ski will run great after it stops beeping.from my experience u either have oil pressure or u dont. where is the oil seperator sensor located.
    Last edited by 03gtx01; 05-31-2008 at 02:39 PM.

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Here's the oil pressure test procedure. The hardest part will be removing the test access plug.

    The original oil filter cover was plastic. The newer engines came with aluminum covers. They're around $25... Ron
    Attached Files Attached Files

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Did you get a code? Mine is doing same thing, I also get a 1520 code.
    2006 rxt Dealer changed the sensor last week, still not fixed.

  6. #6
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by troyheb View Post
    Did you get a code? Mine is doing same thing, I also get a 1520 code.
    2006 rxt Dealer changed the sensor last week, still not fixed.
    A buddy of mine has a 05 RXP with the same exact problem. Dealer replaced all the sensors and still had the problem. Dealer now says the motor has a clog in an oil passage. Right now he's getting a new motor on Sea-doo.
    Last edited by Scott; 06-02-2008 at 09:06 AM.

  7. #7
    no codes are comeing up that is the wired thing. i havent toke it to the dealer to check it but when i pust the set botten 5 times no code come up.

  8. #8
    no more ideas?

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Mine is back at the dealer, if they figure it out I will let you know.

  10. #10
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by 03gtx01 View Post
    no more ideas?
    Have you checked the oil pressure?... Ron

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 gtx 4tec sc
    By LbiPirate in forum Sea Doo Build Threads
    Replies: 34
    Last Post: 05-19-2014, 01:20 PM
  2. 2003 SeaDoo GTX 4TEC SC Intermittent Starting Problem?
    By PWC-Terminator in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-03-2012, 01:43 PM
  3. 2003 GTX SC oil light comes on but oil level is fine??
    By djbauer in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-25-2006, 04:35 PM
  4. 03 GTX 4tec SC Ignition Coil
    By jetworx hawaii in forum 4-Tec Performance
    Replies: 16
    Last Post: 02-27-2006, 11:04 AM
  5. 03 GTX 4tec SC
    By jetworx hawaii in forum 4-Tec Performance
    Replies: 30
    Last Post: 01-08-2006, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •