Results 1 to 10 of 10
  1. #1
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788

    Oil in coolant...Need some input



    Ok so I recently had the engine pulled to try to locate an oil leak that i have been dealing with for a while now. I was losing about a half a quart or so everytime I rode last year and it all ended up in the hull.

    Didnt find any leak on the engine itself when I had it out, so i cleaned the hull spotless and put engine back in. Went out about a week ago for the the first time this year for about a 20 mile trip. Ski ran great, hitting about 8100 rpms, oil level was fine. Coolant level good.

    Went out this past Sunday on a 70 mile trip, experienced oil warning during some rough water riding. Checked oil and was a little low so i filled back to normal level. Also experienced some surging in RPMS at idle from 1800 to 2200. Not real bad but definitely noticeable. And at around 5100 rpms notice a little surge also at one point, but not the whole time.

    Never experienced over heating during the whole trip. When I got back from the ride i checked oil level was low and saw some oil in the hull again. Checked the coolant and it was filled with milky oil and coolant mix.
    Note: Oil in engine was not milky. Looked ok.

    Where should I check first? Should I pull the engine again?

    Thanks!!


  2. #2
    skipSC's Avatar
    Join Date
    Feb 2006
    Location
    Stuart, Fl.
    Posts
    1,445
    +1
    171
    Sound's like a head gasket, but usually the coolant bottle is empty and you get a overheat alarm.

  3. #3
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    Quote Originally Posted by skipSC View Post
    Sound's like a head gasket, but usually the coolant bottle is empty and you get a overheat alarm.
    See I was thinking the same but this bottle was filled up to the cap and I was running good rpms too, but never got a overheat alarm at all. Taking into consideration, It was a long trip.

  4. #4
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Oil cooler issues possibly????

  5. #5
    Sick Puppy's Avatar
    Join Date
    Apr 2008
    Location
    Antigua Caribbean
    Posts
    38
    If your compression checks good, sounds like it could be your waterpump shaft seal letting oil into the cooling system. That does not explain the surging though.

  6. #6
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    Seems like a leak down test would eliminate or comfirm a head gasket issue and is relatively easy to do.

    OBJ

  7. #7
    ride it like u stole it!!!! JRridermd's Avatar
    Join Date
    Sep 2007
    Location
    Maryland
    Posts
    10
    brian, how much oil did you lose on your trip? i am wondering if you can clean your hull again and put overflow tube into a empty gallon jug or 2 liter bottle to determine if its just coming out of bottle or if its leaking from engine somewhere, just a thought....

  8. #8
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    Not a full quart. It read on the very tip of the dipstick.

  9. #9
    Did you ever figure out exactly what the problem was. I have just had the same issue with my RTX 255 with 54 hrs

  10. #10
    does the oil in the hull look milky like the oil in the coolant? if not, may be 2 different issues with the hull oil being pto?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 27
    Last Post: 01-30-2008, 02:26 PM
  2. I need some input on the General....
    By Rodneyae in forum Polaris PWC Performance
    Replies: 24
    Last Post: 05-09-2007, 10:48 PM
  3. I need some input.....
    By mxl16 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 11-05-2006, 10:07 AM
  4. Intercooler with other mods needs some input
    By Jrsrxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-09-2006, 06:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •