Results 1 to 3 of 3

Thread: Gauge Problems

  1. #1

    Join Date
    Mar 2007
    Location
    Nevada
    Posts
    211

    Gauge Problems

    Hey guys, I have a 2000 XP and my fuel gauge is always on empty so it's safe to say it's broken or something in the line is messed up. Does anyone now how to test or know of a fuse possibly? Thanks


  2. #2
    1996XP's Avatar
    Join Date
    May 2008
    Location
    Virginia Beach, VA
    Posts
    168
    Quote Originally Posted by explude View Post
    Hey guys, I have a 2000 XP and my fuel gauge is always on empty so it's safe to say it's broken or something in the line is messed up. Does anyone now how to test or know of a fuse possibly? Thanks
    Chances are your magnets fell off your float that tells how much fuel is in your tank.


    Buy this..............>http://cgi.ebay.com/ebaymotors/Sea-Doo-Fuel-Baffle-Float-Repair-Kit_W0QQcmdZViewItemQQcategoryZ124114QQihZ001QQite mZ110258957811QQrdZ1QQsspagenameZWDVW


    Easy fix. I know when mine was doing that my fuel warning light was on too, Mine is a 96, so i'm not sure how your gauges are set up. But i can 99.9% say the float is your problem.

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    His is a different pickup than our 96's and my 2000 XPL did the same thing. The fuse blew in the top of the pickup.

    Here's a thread on how to fix it...

    http://www.greenhulk.net/forums/show...t=sending+unit

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Gauge Problem
    By Cdoo EtR in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-14-2008, 09:51 AM
  2. Gas gauge problem?
    By seadooingfreak in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-21-2008, 06:04 AM
  3. Gauge problems
    By explude in forum Polaris How To & FAQs
    Replies: 60
    Last Post: 03-26-2008, 08:46 PM
  4. Gas gauge problem!
    By dcs191919 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-05-2007, 07:45 AM
  5. Weird Gauge Problem
    By '02GPRider in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-09-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •