Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Sep 2007
    Location
    Paris,TX
    Posts
    98
    +1
    1

    05 RXP low mph? what should one run?

    It has 38hours on it(bought it a several months ago). I installed the steel clutchs for the SC. This 05 RXP(stock) has low MPH(GPS 63.2) with 1/2 tank,Air temp 88,water temp 82,pretty calm water..no wind. I weigh 260lbs. The tach says 7800-7850.It seems i had a better mph with the trim 2 bars from the top(.2-.4mph difference).


    My wifes 05 GTXL will go(GPS 65.3 with me on it) with the exact same conditions and fuel. Her tach show 8000-8100rpms. It seems she can holeshot me pretty bad(2-3 ski lengths and slowly pull away).

    I checked my oil level(1/2 on stick) and changed plugs. If I held it WOT for 20-30 seconds it shuts down(overtemp light comes on) I took the intercooler lines off and could easly blow through them. I hook a pump up and back flush them for a hour. It had great water flow and hardly any trash came out. So I don't think that is it. A friend of mine suggested it might be the pump...over heating and the low mph. I looked inside the intake grate at the prop and it was alittle chewed up on the edges.
    Here are some pics(not very good)

    If this isn't the problem.. I don't know what is. I am going to install a 4" Air intake and looking at a ebay IC.

    If I do need to replace the prop and wear ring(it has a few small grooves from what it looks like), what should i install prop wise and wear ring (stainless or stock)?

    Any ideas?
    Thank you
    Jeff
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0798.jpg 
Views:	90 
Size:	289.7 KB 
ID:	76590   Click image for larger version. 

Name:	IMG_0795.jpg 
Views:	89 
Size:	316.7 KB 
ID:	76591  
    Last edited by JP05RXP; 06-07-2008 at 09:46 PM.


  2. #2

    Join Date
    Nov 2006
    Location
    NC
    Posts
    361
    That prop is junk ! Get a new prop and wear ring and you'll be good.

  3. #3

    Join Date
    Sep 2007
    Location
    Paris,TX
    Posts
    98
    +1
    1

    what prop?

    I was thinking a 14/19 R, what do you think?

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    prop looks pretty bad. I would go with a 14/19R over the stock prop. You might have to take some out of the trailering edge with stock setup, but if you go rear air then that might be enough to run the prop.

    Also, you might check to see if that is the right prop for that ski?
    I am quite surprised that if that prop looks that way then why dont your pump shoe fins looked damaged. I dont think that prop got that way in that pump but i may be wrong.
    Last edited by skoepp; 06-07-2008 at 09:25 PM.

  5. #5
    I'm all out of favors!!
    Join Date
    Apr 2008
    Location
    Orlando
    Posts
    48
    Just a guess but if your cavitating you'll be spinning more than the rpms your getting. Sounds to me like you've got a dirty intake (corroded S/C compressor housing, or oil blow by in the intake) maybe?? But that wouldn't explain the overheat, I'd check the hose(s) going into the exhaust manifold and gooseneck. If it got hot enough it could have melted the exhaust hose from the waterbox to the resonator(on the inside...creating a restriction in the flow), but this is just my three cents. good luck.

  6. #6
    I'm all out of favors!!
    Join Date
    Apr 2008
    Location
    Orlando
    Posts
    48
    Oh and I forgot to mention that the "GTX platform" hull with 215hp will always holeshot an RXP hull as long as they're both stock.

  7. #7

    Join Date
    Sep 2007
    Location
    Paris,TX
    Posts
    98
    +1
    1
    The SC was took apart and updated a few months ago. Its been in fresh water only and road about 10 hours since then. There was alot of oil in the air intake, alittle in the SC and SC outlet. I am building a 4" intake and installing a catch can. I have check the hoses and blew air through the holes. Every time the Over Temp comes on and beeps, I push the mode button until E-TEMP is displayed....it never shows hot. Lake temp 82 and E Temp 89. Thats the hottest it has ever shown. That is about the same as the GTXL, but her's never has done that.

    Thats for the input.

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Quote Originally Posted by NCRXP View Post
    That prop is junk ! Get a new prop and wear ring and you'll be good.
    You shouldn't insult junk like that..

  9. #9
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by JP05RXP View Post
    The SC was took apart and updated a few months ago. Its been in fresh water only and road about 10 hours since then. There was alot of oil in the air intake, alittle in the SC and SC outlet. I am building a 4" intake and installing a catch can. I have check the hoses and blew air through the holes. Every time the Over Temp comes on and beeps, I push the mode button until E-TEMP is displayed....it never shows hot. Lake temp 82 and E Temp 89. Thats the hottest it has ever shown. That is about the same as the GTXL, but her's never has done that.

    Thats for the input.
    The E Temp mode displays the Environmental (or air) temp, not the engine temp. Many have made the same mistake... Ron

  10. #10

    Join Date
    Sep 2007
    Location
    Paris,TX
    Posts
    98
    +1
    1
    air temp? not exhaust temp... I feel like a DUMB A**

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 rxp low rpm 7700-7800???
    By mike9812121298 in forum 4-Tec Performance
    Replies: 58
    Last Post: 08-19-2016, 02:39 PM
  2. RXT-X what should it run with these mods
    By QWKRN U in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-08-2009, 08:57 AM
  3. 2006 RXP 160 Hrs What should i do now?
    By MyGreenGumby in forum 4-Tec Performance
    Replies: 23
    Last Post: 09-29-2008, 10:45 PM
  4. Replies: 6
    Last Post: 07-06-2008, 09:48 PM
  5. Turbo RXP or GPRXP! What should I DO?
    By Water4fire in forum 4-Tec Performance
    Replies: 86
    Last Post: 11-23-2007, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •