Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33
  1. #1

    96 gsx only 4000 rpms

    just rebuilt the engine, ran decent on the trailer. put it in the water and I can't get it to clear out and make it past 4000 rpms. what do I need to check?


  2. #2
    What does it do when you try to rev it up? Do you get a bogging or does it sound like it's hitting the rev limitter?

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Did you rebuild or clean the carbs? Sounds like it's loading up on fuel from a leaking needle and seat.

  4. #4
    I just cleaned the carbs. but I changed to another set with the same result.

  5. #5
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    exhaust restriction somewhere? baffles in the waterbox loose?

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Change your spark plugs, then if no improvement, check your RV timing.

  7. #7
    already changed the plugs. it seems that under a load is when it won't clear out.

  8. #8
    Could be the coil breaking down. Try checking out the primary winding for high resistance.

  9. #9
    Reservoir Dawg BobOnThis's Avatar
    Join Date
    Oct 2007
    Location
    O-H-I-O
    Posts
    331
    +1
    3
    Quote Originally Posted by cardudenc View Post
    just rebuilt the engine, ran decent on the trailer. put it in the water and I can't get it to clear out and make it past 4000 rpms. what do I need to check?
    Bud, mine is doing the EXACT same thing and I just rebuilt my motor and went through all the steps people are saying as well and still no better. I sent it to a shop and hopefully I will have an answer for you tomorrow. Here is my thread..
    http://greenhulk.net/forums/showthread.php?t=59896

  10. #10
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Quote Originally Posted by JayZ View Post
    exhaust restriction somewhere? baffles in the waterbox loose?
    +1

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 900 zxi only 4000 rpm
    By dmassey88 in forum Kawasaki Open Discussion
    Replies: 30
    Last Post: 08-13-2012, 09:27 PM
  2. 96 GSX still missing rpms......
    By steelers87 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-02-2010, 09:04 PM
  3. 96 GSX only at 6000rpm WOT, next steps?
    By steelers87 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-21-2010, 10:42 AM
  4. Please help, 96 GSX bogs @ high RPM, and weird electrical issue
    By Mike94ZLT1 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-14-2009, 11:49 PM
  5. '96 slx780 - only 5500 rpm's?
    By sissabagama in forum Polaris PWC Performance
    Replies: 8
    Last Post: 06-18-2007, 03:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •