Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1

    RXP "slow speeds"

    I am a new member and thought I should join this forum to find out some information on my 2004 RXP that I can't figure out. My ski only does 66.4-67.5 mph, gps readings. Mods include: solas 14/19 impellar, riva power filter air intake,free-flow exhaust, opas block-off kit, 2 degree pump wedge. I have the Riva top loader intake grate but have not installed it yet, my friend says that may reduce my top speeds {I hope not}. Also purchased Riva clutch washers and Vortech 2 impellar but have not installed those yet either. Should I stop because I no longer want to waste $$ to go slower than stock. Should I get the venturi nozzle with a 81 mm ring and the VTS x-tension rod? What is the problem? Spending $$ and not seeing the 74 MPH everyone says. My top speed yesterday on 66 degree water and glass water conditions and 73 air temp although humid air was 66.4 @ 7850 RPM. I'm so dissapointed, I may sell my boat. Help!


  2. #2
    buddydoo's Avatar
    Join Date
    Oct 2005
    Location
    houma
    Posts
    958
    +1
    9
    What is your oil level when the motor is hot,it should be no more than half,1/4 from the bottom been is best.That could rob for your top end and bring your rpms down which should be at 8100 rpms.

  3. #3
    never checked oil level when motor is hot, although checked it cold and it was clean and right at the full mark. Maybe not installing my intake grate and the nozzle with the 81mm ring is my problem. My boat also reaches its top speed with the trim a little below half way down which makes no sense either, it should make better top speed with the nozzle trimmed all the way up you would think but that is not the case. Is the pump wedge causing the problem because I do not have a VTS extension rod?

  4. #4
    buddydoo's Avatar
    Join Date
    Oct 2005
    Location
    houma
    Posts
    958
    +1
    9
    Try checking the oil when hot,oil expands when it is hot.This was my problem till jerry let me in on this.

  5. #5
    Is my oil level to high? What would that have to do with RPM? My max RPM's are 7850.

  6. #6
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    You do not have to have the extension rod. Most will tell you that you will be able to achieve a better hole shot with it since you would be able to trim down further. I do not have the extension and it has not had any effect on my RPMs or speed. Where as most of the guys running the extension see the best RPMs and speed with the trim up 1-2 clicks above neutral. I have the best speed running at neutral on the trim gauge without the extension.








    Quote Originally Posted by QUARTS View Post
    never checked oil level when motor is hot, although checked it cold and it was clean and right at the full mark. Maybe not installing my intake grate and the nozzle with the 81mm ring is my problem. My boat also reaches its top speed with the trim a little below half way down which makes no sense either, it should make better top speed with the nozzle trimmed all the way up you would think but that is not the case. Is the pump wedge causing the problem because I do not have a VTS extension rod?

  7. #7
    Thank-You, you just saved me $90. I hit my best top 1 click below half way. I still need to know answers for my low top end and rpm's. I will not order the VTS extension rod now. Do I need 42# injectors to flow more fuel for ny mods? What about the cooler t-stat? Why is it $180? I thought t-stats were maybe $30

  8. #8

    Join Date
    Nov 2006
    Location
    NC
    Posts
    361
    Quote Originally Posted by QUARTS View Post
    never checked oil level when motor is hot, although checked it cold and it was clean and right at the full mark.
    This would be your problem.

  9. #9
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    Just remember if you later want the better holeshot and want to run the wedge, you will need the extension. Have you checked the slip on your supercharger ? If it is low that can cause you to loose performance also. Have you ever seen 8100 RPMs ?
    When I ran the Riva Stg. 1 with the Rotax Racing impeller(about the same as the Green Wheel & Gen II) I would get just over 74 mph. This was with the Riva front intake, stock intercooler and stock injectors. The cooler t stats can help in high heat, high humidity locations. The Rotax Racing t stat costs the most and is complete ready to bolt on. The Riva mod you just replace the T stat in your current housing.

    http://greenhulk.net/forums/showthread.php?t=16773 This is almost a must read when first starting to mod. Will answer a bunch of your current and upcoming questions.





    Quote Originally Posted by QUARTS View Post
    Thank-You, you just saved me $90. I hit my best top 1 click below half way. I still need to know answers for my low top end and rpm's. I will not order the VTS extension rod now. Do I need 42# injectors to flow more fuel for ny mods? What about the cooler t-stat? Why is it $180? I thought t-stats were maybe $30
    Last edited by DaveC; 06-08-2008 at 12:56 PM.

  10. #10
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by QUARTS View Post
    never checked oil level when motor is hot, although checked it cold and it was clean and right at the full mark. Maybe not installing my intake grate and the nozzle with the 81mm ring is my problem. My boat also reaches its top speed with the trim a little below half way down which makes no sense either, it should make better top speed with the nozzle trimmed all the way up you would think but that is not the case. Is the pump wedge causing the problem because I do not have a VTS extension rod?
    To check your oil, warm up the engine, let it idle for 30 seconds, turn it off, let it sit for 30 seconds and check the oil. Note that the ski should either be level in the water or level on the trailer... Ron

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Stock top speeds?
    By dgmoore in forum 4-Tec Performance
    Replies: 29
    Last Post: 06-15-2016, 05:25 PM
  2. 05 Seadoo RXP Overheating and Slow Speed
    By brad2510 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-13-2012, 03:26 PM
  3. RXP needs more speed
    By Antiguan FZR in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-28-2007, 01:14 PM
  4. Help 04 RXP is slow!
    By Matth3wJL in forum 4-Tec Performance
    Replies: 21
    Last Post: 09-06-2006, 09:41 AM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •