Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43

    trouble with primer instalation

    How do i intall the little brass fittings into the carb bodies? they tend to just fall out with or without the littole plastic bushing from the choke plates installed. What do you guys recomened for permanent instalation? Thanks as always.


  2. #2
    I put some sealant on them and then stuffed them in. I kept the plastic bushings in the holes. You can even epoxy them in if you are certain you will want them in the carbs forever.

  3. #3
    sometimes they tend to be loose . if just slightly I use locktite gel if really loose I use jb weld

  4. #4
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    I was thinking of useing some kind of sealant. Can i use permatex rtv sealant, its that orange stuff.

  5. #5
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    loctite has a product that's like epoxy and permatex...it seals good and has the properties of a threadlocker...I've seen it in demonstration and works real well..maybe someone knows the name of it

  6. #6
    RTV would seal but when u go to remove the tubing I'm sure the flexible RTV would fail when u pull it

  7. #7
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    what about JB weld?

  8. #8
    Quote Originally Posted by ZMANN View Post
    sometimes they tend to be loose . if just slightly I use locktite gel if really loose I use jb weld

  9. #9
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    Quote Originally Posted by ZMANN View Post
    I should probably read all the posts before posting ...my bad

  10. #10
    I was just messing with u I skim and post all the time

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawa Triple w/CV carb Primer Install with Pics
    By PEVO in forum Kawasaki Tech Tips and Info
    Replies: 3
    Last Post: 06-02-2009, 12:28 PM
  2. Primer Install Trouble
    By bedbug357 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 03-18-2007, 11:53 PM
  3. Trouble with Riva SC plactic hoses
    By Alex13 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-28-2006, 08:32 PM
  4. For those having trouble with the stock class ECU
    By Green Hulk in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-17-2006, 12:21 PM
  5. Will I see any increase with just installing a Solas 14/19R
    By rxp_boy in forum 4-Tec Performance
    Replies: 6
    Last Post: 11-19-2005, 11:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •