Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    2006rxp Sudden Loss of power and vibration

    Greets all .. was out Saturday riding my 2006 rxp. Rough water rider, love windy days.

    Suddenly.. nasty vibration at anything above 7mph. Ile was fine so idle a miles back to dock and loaded up. I looked in the jet exit this morning and found about a 6 inch piece of 1/2" blue nylon rope that had knots in it. I can also see blue marks whereit ran through the jet. (round and round she goes). I did not want to try going any faster once I felt the crazy vibration.

    After searching the goo I found this site and am freaking out know about this SC clutch issue. My 2006 RXP and RXT are stock (RXP 31hr, RXT 25hr.)

    Could this small piece of rope have been the cause of the vibration?
    Or could this be a combination of the SC issue? I've not had any previous issues. I started it this am, after removing the rope,and looked at the hose leaving the SC and I can see it swelling like it does on the RXP. So, I'm assuming the (ass outa you and me) the SC is prolly ok for the moment.

    I need to get the ceramic out these ski's before they hit the water again.
    Is this issue fixed on the 2008's, and if so what was the fix? Did they go metal washer and ceramic ball's?

    Last but not least I see oil level is above the full mark, straight from the seadoo dealer. Sould it be in the middle when cold?

    I'm a DIY type person. How difficult is it to fix the SC the right way?

    wtf happend to excellence in the country?

    Thanks in advance,
    John.


  2. #2
    El Tartaro luismendez25's Avatar
    Join Date
    Jun 2005
    Location
    Orlando, Fl
    Posts
    555
    The vibration was definetly the rope stuck in the pump. Change those ceramics ASAP. Before you take the S/C out unhook the hose that goes from the S/C to the throttle body and try to spin the fan. If you cannot spin it the your ceramics are good but change them.As far as your oil it needs to be between the full and low mark. Welcome to the best PWC site where you will learn allot and make real good friends.

  3. #3
    Quote Originally Posted by rohameto View Post
    Greets all .. was out Saturday riding my 2006 rxp. Rough water rider, love windy days.

    Suddenly.. nasty vibration at anything above 7mph. Ile was fine so idle a miles back to dock and loaded up. I looked in the jet exit this morning and found about a 6 inch piece of 1/2" blue nylon rope that had knots in it. I can also see blue marks whereit ran through the jet. (round and round she goes). I did not want to try going any faster once I felt the crazy vibration.

    After searching the goo I found this site and am freaking out know about this SC clutch issue. My 2006 RXP and RXT are stock (RXP 31hr, RXT 25hr.)

    Could this small piece of rope have been the cause of the vibration?
    Or could this be a combination of the SC issue? I've not had any previous issues. I started it this am, after removing the rope,and looked at the hose leaving the SC and I can see it swelling like it does on the RXP. So, I'm assuming the (ass outa you and me) the SC is prolly ok for the moment.

    I need to get the ceramic out these ski's before they hit the water again.
    Is this issue fixed on the 2008's, and if so what was the fix? Did they go metal washer and ceramic ball's?

    Last but not least I see oil level is above the full mark, straight from the seadoo dealer. Sould it be in the middle when cold?

    I'm a DIY type person. How difficult is it to fix the SC the right way?

    wtf happend to excellence in the country?

    Thanks in advance,
    John.
    Send your Super Charger to Jerry (Green Hulk) and get it fix. Did you find any lobster at the end of the rope? check your wear ring too.

  4. #4
    snowrunner's Avatar
    Join Date
    May 2006
    Location
    Ray Twp, Michigan
    Posts
    474
    +1
    2
    Make sure the pump liner isn't damaged.

  5. #5
    Quote Originally Posted by luismendez25 View Post
    The vibration was definetly the rope stuck in the pump. Change those ceramics ASAP. Before you take the S/C out unhook the hose that goes from the S/C to the throttle body and try to spin the fan. If you cannot spin it the your ceramics are good but change them.As far as your oil it needs to be between the full and low mark. Welcome to the best PWC site where you will learn allot and make real good friends.

    Can I remove the hose with the ridges and the standard type clamp, or does it have to be the factory clamp on the hose going to the throttle body?

    And thanks for the fast reply!!!

  6. #6
    Quote Originally Posted by Jammer 1 View Post
    Send your Super Charger to Jerry (Green Hulk) and get it fix. Did you find any lobster at the end of the rope? check your wear ring too.

    Only lobster was me.. forgot to put massive amounts of sun screen on.. was so excited to see a ruff lake I just went wako.. I remember today though .. haha.

  7. #7
    Quote Originally Posted by rohameto View Post
    Only lobster was me.. forgot to put massive amounts of sun screen on.. was so excited to see a ruff lake I just went wako.. I remember today though .. haha.
    LOL, Your'e gonna be O K. Yes on the hose clamp ? That is just factory clamps. I am just running regular stainless clamps on mine. YOU have to use good quality stainless steel products.

  8. #8
    I know your a DIY (Do It Yourself) kind of person. You can use that skill to take the Super Charger out of the ski and box it up and send it off to Jerry (Green Hulk) you can't beat the price for piece of mind that it's done right. There is only 2 people I trust to do my Super Charger Jerry and Nils, No offense to the rest. It is what it is for me.

  9. #9
    Ok lower hose detached and I cannot spin the fan blades freely. I can move it, but its really hard, enough to leave indentions in my fingers.

  10. #10
    Quote Originally Posted by rohameto View Post
    Ok lower hose detached and I cannot spin the fan blades freely. I can move it, but its really hard, enough to leave indentions in my fingers.
    what are you trying to acomplish at this point?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power and heavy vibration
    By taxsux in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-23-2011, 07:44 AM
  2. Loss of power and RPM after engine is warmed up ...
    By OBrienCJ in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-26-2011, 09:55 PM
  3. Loss of power and rpm
    By 04DarkShadowGT in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-27-2009, 06:22 PM
  4. Sudden loss of power diagnosis?
    By ascauto3 in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 05-09-2009, 01:09 PM
  5. Sudden loss of power diagnosis?
    By ascauto3 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 05-09-2009, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •