Results 1 to 10 of 10
  1. #1

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592

    What the hell happened...huge vibration awful sound

    Hey guys, i was riding my 04 rxp somewhat hard, slowed down to idle for a boat and was gonna jump the wake, put on some power and it shuttered and wouldnt really go. i tried to start off slow knowing something was wrong, it kept doing it. idled about a mile after i checked for obvious things. Then i tried it and it went ok so i limped it back to a buddys boat and let it sit for awhile. went to go home and it was fine, seems like the supercharger cluch may have been really hot or something like that... maybe a spun prop? i dunno. havent investigated yet im tired.
    Mods

    (i have a hks blow off valve but it was not installed when this happened, i thought it might have been leaking boost but it wasnt).

    by the way, why the hell am i only going 72mph with a rude charger.. 7800rpm slip moment was good, i had it out the day before all this happened and checked it on the bench...95 inlbs, guess i gotta pull it yet again.


    riva grate
    solas 15/20r with 4mm out the prop
    rude charger
    riva pump nosel thingys
    4" intake
    metal washers (at least before the rude charger)
    custom shorty/gutted wb
    front motor mount
    2 degree wedge
    custom intercooler, metal pipes
    hks super sequential bov
    Last edited by BoostedH23a1; 06-08-2008 at 03:04 PM.


  2. #2
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Sounds like you may have sucked something up.

  3. #3

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    hopefully i willl get off that easy but thats usually not my luck. any clue as to the slow ass mph on the rude? at the rpm its seeing 10.5-11 psi at the most. i know thats low but im on a stock ecu

  4. #4
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    What do you have for fueling? What size injectors?

  5. #5

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    stock injectors rude rrfpr

  6. #6
    2006 RXT dave262626's Avatar
    Join Date
    Nov 2007
    Location
    Kansas
    Posts
    164
    Shouldn't he be running 42 injectors?

  7. #7

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    Quote Originally Posted by dave262626 View Post
    Shouldn't he be running 42 injectors?
    12.1 AFR AT 60PSI

  8. #8

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by BoostedH23a1 View Post
    12.1 AFR AT 60PSI
    my rpms are the same at the moment 7850, 70.1 mph, i think ive still got a boost leak on the plastic manifold, i had to repair the manifold as it was leaking on the seam, ive an alloy one on order from gerry, hope that cures it. boostedH23, run it on the hose and put your hand between the manifold and hull and blip the throttle, try to feel for drafts, regards bill

  9. #9
    Like 04RXP22 said... I think you probably sucked something up. It has happend to me twice already this year. The first time I sucked up a burr that got wedge on a prop blade. Same exacty symptoms that you had. I had to pull the machine out to remove it. Then a couple of weekends ago I sucked somthing up again. It dislodged it self after I gave a little bit of gas. Both times it happend I had slowed down and was idling around.

  10. #10

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    well i did pull out a little peice of sea grass....*ducks head to avoid the hammer*

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What the hell happened? iBr Reverse at high speed??
    By sea-one in forum Sea Doo Open Discussion
    Replies: 171
    Last Post: 02-17-2017, 11:31 PM
  2. What the hell happened ?? pics inside. 00 1200 xl ltd.
    By chevydog in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 08-13-2012, 08:24 PM
  3. now what the hell happened here ?????????????
    By duty in forum 4-Tec Performance
    Replies: 19
    Last Post: 07-04-2011, 08:05 AM
  4. What the hell do I do???
    By BlackHawk in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 05-09-2006, 03:20 PM
  5. Someone tell me what the hell this is
    By peteshauling in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 08-28-2005, 10:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •