Results 1 to 10 of 10
  1. #1

    i think i got big trouble

    well...let me say this was only my 2nd time out w/ my ski. we unloaded it and my brother went to get on and it was riding a little low, so he asked if i had the plug in and it hit me...holy s$#@! so we hauled tail back to get it loaded up to drain and the damage was already done. water everywhere. i took the air filter and all off and water is in the carbs, then took the plugs out and water is in the cylinder. i know, it's my own fault, but what can i do to fix it? do i have to take the motor apart or is there a plug somewhere? that would be pretty nice actually! thanks for any help.

    chris

    oh yeah...it's a '95 SL750
    Last edited by Vanilla_Gorilla; 06-08-2008 at 08:31 PM.


  2. #2
    gorilla03's Avatar
    Join Date
    Sep 2006
    Location
    stevens point wi
    Posts
    3,774
    +1
    5
    Quote Originally Posted by Vanilla_Gorilla View Post
    well...let me say this was only my 2nd time out w/ my ski. we unloaded it and my brother went to get on and it was riding a little low, so he asked if i had the plug in and it hit me...holy s$#@! so we hauled tail back to get it loaded up to drain and the damage was already done. water everywhere. i took the air filter and all off and water is in the carbs, then took the plugs out and water is in the cylinder. i know, it's my own fault, but what can i do to fix it? do i have to take the motor apart or is there a plug somewhere? that would be pretty nice actually! thanks for any help.

    chris

    oh yeah...it's a '96 SL750

    chris,
    pull the heads off the cylinders and post some pictures of them...also open the electrical box and make sure that is dry....was it running when you put it back on the trailer?

    and by the way let me welcome you to the hulk, there's alot of polaris junkies who know alot about these skis

  3. #3
    thanks for the welcome...no it wasn't running when it went back on the trailer. all the electrical is fine. just water everywhere else. i'm gonna take it down tomorrow, so i'll post some pics then.

  4. #4
    check this out .. but whatever u do don't let it wait! http://www.sbtontheweb.com/forum/showthread.php?t=12031

  5. #5
    do you think it could wait till tomorrow?

  6. #6
    it will wait but the rust won't . I can't tell you how many people post this question and we never hear from them again

  7. #7
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by ZMANN View Post
    check this out .. but whatever u do don't let it wait! http://www.sbtontheweb.com/forum/showthread.php?t=12031
    +1 big time
    get that thing fired up TONIGHT its easier to say "sorry" to niebors/law officer,,,,than it is to rebiuld that sucker
    get it fired
    oh and WELCOME TO GREENHULK
    mattman

  8. #8
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by Vanilla_Gorilla View Post
    do you think it could wait till tomorrow?
    NO
    NO
    NO

  9. #9
    did u see the video? it's a lot faster to get it running than it is to tear it down

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Welcome to the Hulk.

    There are 3 drain plugs at the base of the crankcase on the exhaust side. See if you can access them, and fog the engine ASAP....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1992 SL 650 big trouble!
    By chazdo2 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-26-2008, 08:22 AM
  2. I think I got a slow 250X.
    By SRTOutlaw in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 06-03-2008, 08:37 PM
  3. We Got Some Trouble!!!! Rxp-x!!!
    By EGGonz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 48
    Last Post: 08-29-2007, 01:57 PM
  4. Think I got screwed...
    By bryan428 in forum Polaris Open Discussion
    Replies: 16
    Last Post: 06-17-2007, 09:46 PM
  5. SLT780 No power= big trouble.
    By Tony in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-10-2007, 07:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •