Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1
    Flat water sucks! yz426er's Avatar
    Join Date
    Apr 2007
    Location
    Woodbridge, Ca
    Posts
    119

    My RXT-X is falling apart!

    9 hours and I have some issues. The hood gas shock came unhooked from the ball mount and the bracket bolts were loose and the hood was difficult to open as if the pin latch was mis-aligned. Also, inside the hull there is a fuse box, at the front there is a water tight connector with pins, I found a wire assembly that was disconnected. Is this connector supposed to be connected? or is this some type of diagnostic tool? These are minor issue really, but still bothersome.


  2. #2
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Pics of the harness might help.

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by yz426er View Post
    9 hours and I have some issues. The hood gas shock came unhooked from the ball mount and the bracket bolts were loose and the hood was difficult to open as if the pin latch was mis-aligned. Also, inside the hull there is a fuse box, at the front there is a water tight connector with pins, I found a wire assembly that was disconnected. Is this connector supposed to be connected? or is this some type of diagnostic tool? These are minor issue really, but still bothersome.
    I havent had any of those problems with hood. I think someone else posted about having hood problems, post pic of assembly and i will take a look for you.

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    that plug/harness is for dealer diagnostics

  5. #5
    Flat water sucks! yz426er's Avatar
    Join Date
    Apr 2007
    Location
    Woodbridge, Ca
    Posts
    119
    photos of harness in question
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	disconnect.jpg 
Views:	131 
Size:	678.3 KB 
ID:	76839   Click image for larger version. 

Name:	connect.jpg 
Views:	97 
Size:	633.1 KB 
ID:	76840  

  6. #6
    hereitcomes's Avatar
    Join Date
    Sep 2007
    Location
    Lagrangeville, NY
    Posts
    100
    That is plugged in on mine, I just checked.

  7. #7
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,338
    +1
    121
    Looks like the female end isnt connected to anything. Looks like just a holder for that connector, dealer hookup?

  8. #8
    Banned User
    Join Date
    May 2008
    Location
    Lake Havasu
    Posts
    2,924
    +1
    27
    My hood latch shock come off after the first hour. Took to dealer and they redrilled the latch and it worked for another hour, then came off again.

    Taking it into dealer tomorrow for 10 hour service, and they will install new latches, hope that helps. Its a bitch holding the hood up with your head.

  9. #9
    Married the love of my Life Mayday 2008 SuperCharged03's Avatar
    Join Date
    Apr 2007
    Location
    With my Wife Michelle!!!!
    Posts
    812
    Quote Originally Posted by yz426er View Post
    photos of harness in question
    I am pretty sure That is for the dealer to hook the BUDS computer to it.

  10. #10
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by SuperCharged03 View Post
    I am pretty sure That is for the dealer to hook the BUDS computer to it.
    Wow!! Congrats on your marriage!! You guys look very happy!! Best wishes!!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Soo my seat is coming apart at the threads on my rxt....
    By Seadooguy101 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-24-2014, 10:36 AM
  2. My sport is falling apart...
    By two2curupt in forum Open Discussion
    Replies: 5
    Last Post: 12-05-2008, 11:43 PM
  3. My RXT Is Loving It!!
    By golson in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-17-2006, 05:03 PM
  4. My RXT Saga is Over
    By Pettee in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 03-20-2006, 11:10 PM
  5. is that MY wife I see towing MY RXT....BACKWARDS?!?!?!
    By SKR8PN in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-06-2005, 11:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •