Results 1 to 4 of 4
  1. #1

    1995 Polaris 750 SLT "HELP"

    I fill up gas tank, can use half a tank and it won't run anymore,fill it up runs fine till half gone. Where should I start. I have pulled gas tank out and also we are taking oil injection pump out and installing plate and going to mix ourselves seems to be highly recommended, Thanks for any help you may have to offer!!!!


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    WELCOME to the Green Hulk Forums!!
    Check the pick ups on the sending unit if applicable.
    By running poorly, do you mean it limits at roughly 4200RPM??
    Does it have a single pick-up/sending unit or seperate sender and seperate pick-up?
    Last edited by ph2ocraft; 06-08-2008 at 10:14 PM.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by Sasquach View Post
    I fill up gas tank, can use half a tank and it won't run anymore,fill it up runs fine till half gone. Where should I start. I have pulled gas tank out and also we are taking oil injection pump out and installing plate and going to mix ourselves seems to be highly recommended, Thanks for any help you may have to offer!!!!
    Welcome to the Hulk!

    There have been a number of discussions regarding pre-mix on Polaris. If you maintain the oil injection system, replacing the oil lines before they get too old, then the oil pump itself is actually quite reliable. You can search here for more input on the choice.

    Have you pulled the sender unit out of the fuel tank?
    Check it for cracks or damage in the fuel intake.

    Have you downloaded the 1992-1998 Service Manual?

  4. #4

    Join Date
    Jul 2007
    Location
    Alabama Gulf Coast
    Posts
    206
    Have you tried to continue running with 1/2 tank with the selector on reserve? I would dare say you have a pick up line in the tank cracked right at the half tank level mark. If it will run on reserve this would be verified as the main and reserve lines are seperate on the 95 SLT.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 1995 Polaris 750 SLT
    By durango9099 in forum Polaris Classifieds
    Replies: 2
    Last Post: 06-11-2015, 03:32 PM
  2. WTB 1995 polaris 750 slt. looking for thumb throttle replacement
    By mcoit1 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 09-17-2012, 06:09 PM
  3. need help!1995 polaris 750 slt Electrical!
    By stutman in forum Polaris Tech Tips and Info
    Replies: 5
    Last Post: 08-01-2012, 11:19 AM
  4. 1995 polaris 750 slt goes into limp mode
    By natehodge in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-10-2011, 02:27 AM
  5. hard starts on 1995 polaris 750 slt
    By zakatak in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-19-2009, 11:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •