Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99

    Unhappy 93 sl750 Iam getting discouraged

    OK I need help again My 93 sl750 starts somewhat ok on the trailer I need
    to rebuid the carbs. But will the carbs cause the ski to start on the trailer
    but once I put it in the water it will not start? I have no water in the cylinders. I have good spark and the battery is new. Also I have read some threads here about not buying aftermarket carb rebuild kits. Is their a reason for this SBT has them at $15.00 compared to $45.00 X 3
    Last edited by jmule98; 06-09-2008 at 07:29 AM.


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Check your compression. If you have weak compression, it could start with no load on the impeller, but not be able to rev high enough in the water.

    This could also be the case if either your battery is bad (doesnt matter if its new) and or your starter is going on you.

    What RPM are you seeing on crank
    \in water?
    \out of water?
    Battery voltage static?
    While cranking? (not on the dreamometer if you have one)


    More will chime in, but here is a place to start!
    Last edited by seaobin; 06-09-2008 at 07:46 AM. Reason: spelling

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Do you have a multi-meter?
    What is the battery voltage measured right on the battery posts (not the wires or bolts connected to the posts), BEFORE cranking?
    Must be 12.5 volts or better.
    Anything less, the battery needs charging, or is dying.

    During cranking (out of the water is fine, but remove the lanyard, spark plugs installed), what is the battery voltage?
    Should be WELL over 10.5 volts, preferably 11.x volts or better.

    What RPM does the MFD show during cranking?
    A good battery and starter should show 600-1,000RPM during cranking, if I recall correctly.

    Note: Don't crank continuously for more than 10-15 seconds. Then let it cool down for several minutes.

    In the water, the impeller will have added turning resistance from the water during starting. If your battery or starting system is on the edge, then that might be enough to prevent starting.

    Also, if the carbs need service, they might not be delivering fuel properly during slow speed cranking.

    Have you updated your fuel system, replaced the single outlet fuel pump with a triple outlet pump, replaced all the fuel lines, etc?
    Remove the auto-cock, if yours still has one, clean and lube the fuel selector O-rings, replace the fuel filter, check the water-fuel separator...

  4. #4

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99
    I have no way of knowing the rpms it does not have a gauge and I have not updated the fuel system since the ski last season was performing perfect. This started happening after I installed new reeds I used fmf torque reeds they were different than the manuf. reeds, could that be part of it the new reeds have 2 pedals on them and the old had 3. also my diaghrams show ware . I have not checked compression but I will and I will volt test the battery.

  5. #5
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Quote Originally Posted by jmule98 View Post
    I have no way of knowing the rpms it does not have a gauge and I have not updated the fuel system since the ski last season was performing perfect. This started happening after I installed new reeds I used fmf torque reeds they were different than the manuf. reeds, could that be part of it the new reeds have 2 pedals on them and the old had 3. also my diaghrams show ware . I have not checked compression but I will and I will volt test the battery.
    You put the new reeds on the old cages? If so, you have the wrong reeds.

  6. #6

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99
    Quote Originally Posted by starflight View Post
    You put the new reeds on the old cages? If so, you have the wrong reeds.
    How will I be able to tell if they are the wrong reeds? they fit the cages.

  7. #7
    If you have the stock cages in there with the 2 petal reeds, thats probably your problem. I bought a set on ebay that I couldnt use because they were 2 pedal...even though they said they were made for my ski.

  8. #8
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Quote Originally Posted by jmule98 View Post
    How will I be able to tell if they are the wrong reeds? they fit the cages.
    The 2 petal reeds will leave a opening in the middle of the center portion of the cage. It will not run properly w/ a 2 petal reed on a 3 petal cage.
    Last edited by starflight; 06-09-2008 at 02:35 PM.

  9. #9

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99
    Quote Originally Posted by ryanbgb22 View Post
    If you have the stock cages in there with the 2 petal reeds, thats probably your problem. I bought a set on ebay that I couldnt use because they were 2 pedal...even though they said they were made for my ski.
    ryan, were they the fmf torque reeds that you bought on ebay?

  10. #10
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    i bought the same ones

    let me know what you find out

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel Tank Pickup Tubes '93 SL750
    By nu2sport in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-02-2007, 09:46 AM
  2. 95 and 93 SL750 Carb settings
    By novanuttz in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-29-2007, 02:36 PM
  3. 93 SL750 restrictor help
    By novanuttz in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-17-2007, 10:03 PM
  4. 93 SL750 return restrictor
    By novanuttz in forum Polaris Open Discussion
    Replies: 12
    Last Post: 04-16-2007, 12:20 AM
  5. RPM's of a 93 SL750
    By ph2ocraft in forum Polaris PWC Performance
    Replies: 11
    Last Post: 09-12-2006, 12:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •