Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Code 1520?

  1. #1
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    963
    +1
    2

    Code 1520?

    Does anyone know of a 1520 Oil code, cause and how to fix it?
    I知 get it when I知 at WOT and let off quickly.....I have been using AMSOIL but then switched to Castrol GTX 10w-40, because of the engine blowing out so much oil at WOT ...could this be the reason?


  2. #2

    Join Date
    Aug 2007
    Location
    Worthington, MN
    Posts
    100
    Somtimes it's sensors or a regulator problem even though you might be getting correct oil pressure. Those are the two prolems I had. That's all I know.

  3. #3
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    963
    +1
    2
    How did you fix it...or do you still have the problem?

  4. #4

    Join Date
    Aug 2007
    Location
    Worthington, MN
    Posts
    100
    My dealer replaced the sensor and the regulator. Not much help sorry.

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I am having the same problem, oil light, limp mode, 1520 code. Also no one, despite all the knowledge on this site ( I am not trying to be a smart ass) seems to know what 1520 code is.

  6. #6
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    963
    +1
    2
    That sucks...some1 must know

  7. #7
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    963
    +1
    2
    tt

  8. #8
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    Quote Originally Posted by BlackHawk View Post
    Does anyone know of a 1520 Oil code, cause and how to fix it?
    I知 get it when I知 at WOT and let off quickly.....I have been using AMSOIL but then switched to Castrol GTX 10w-40, because of the engine blowing out so much oil at WOT ...could this be the reason?
    I would check the oil pressure first.Find out why your blowing oil out(go back to seadoo oil)Change the sensor.What mods do you have?

  9. #9

    Join Date
    Jul 2009
    Location
    Dubai
    Posts
    1

    1520

    i have same that problem .. it happen today when i raid it .. i don,t know what it mean ?? maby the oil feltar is jam ??

  10. #10
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,763
    +1
    29
    Check for collapsed oil filter.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tip: Trouble codes for 4 Tec's
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 73
    Last Post: 06-02-2017, 07:34 PM
  2. Code 1520
    By cliff0413 in forum 4-Tec Performance
    Replies: 19
    Last Post: 09-12-2011, 10:45 AM
  3. error code P-1520 anyone?
    By scottyj in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-08-2009, 04:36 PM
  4. 2004 RXP Paint Codes
    By Thomas in forum Sea Doo How To & FAQs
    Replies: 5
    Last Post: 07-23-2007, 12:14 AM
  5. Getting codes P0261, P0264, and P0267
    By Jrsrxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-27-2005, 02:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •