Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Waverunner XLT 1200 won't go over 20 MPH after taking on water

    Kids got the ski rope stuck underneath, flipped the jetski over to try to get it out and got it filled with water.

    I got the rope out, drained the oil, dried the cylinders (with air compressor and letting it sit for a week), replaced the plugs, put some DW40 inside the cylinders and took it to the water. It runs but won't go past 20 MPH. Plus it shuts off and then won't start (as though it is out of battery), then after a few minutes it turns on.

    Any recommendations?

    Thanks in advance.


  2. #2
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    Check compression.... sounds like it might be seizeing....

  3. #3
    Thanks. How do I do that?

  4. #4
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115

  5. #5
    Man, you are awesome, thanks!

  6. #6
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    No problem... hope it works out...
    chris

  7. #7
    I did the compression test and #1 is around 100, #2 is 0 (yes zero, I tried it twice), #3 is around 110. I am guessing that it is time to take it to the shop and get ready to part with some serious cash but I thought I mention it and see if there are any suggestions.

    Thanks.

  8. #8
    OLD # 7 IEGPR's Avatar
    Join Date
    Dec 2006
    Location
    Rialto CA
    Posts
    964
    +1
    6
    Where are you located?? There might be someone here who would help you out and save a lot of money. And if you do take it somewhere post it first.

  9. #9
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    Quote Originally Posted by mmr11408 View Post
    I did the compression test and #1 is around 100, #2 is 0 (yes zero, I tried it twice), #3 is around 110. I am guessing that it is time to take it to the shop and get ready to part with some serious cash but I thought I mention it and see if there are any suggestions.

    Thanks.
    if you have some good tools i.e sockets and spanners or dont mind buying some it can be done on forum

    all the manuals are here for free and the guys here are second to none

    even better have you got a digital camera for pics if you/we get stuck on a part of the re-build..

    if the build is done by yourself so will save mega $$ and know and love that ski better than ever...

  10. #10
    CHICKA WAH WAH bren's Avatar
    Join Date
    Sep 2007
    Location
    Cairns, Australia
    Posts
    595
    Quote Originally Posted by Hydrotherapy View Post
    if you have some good tools i.e sockets and spanners or dont mind buying some it can be done on forum

    all the manuals are here for free and the guys here are second to none

    even better have you got a digital camera for pics if you/we get stuck on a part of the re-build..

    if the build is done by yourself so will save mega $$ and know and love that ski better than ever...
    so true words man

    I just rebuilt my XLT engine and it was the best thing I could ever have done. Theres nothing like getting out there full noise and knowing you made it happen.

    They are actually very simple machines once you get that horrid exhaust out

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XLT 1200 Won't Go Above 4000 RPM
    By zricketts in forum Yamaha Old School Skis
    Replies: 12
    Last Post: 08-14-2016, 05:48 PM
  2. XLT 1200 won't go faster than 30 mph
    By butch708 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 06-04-2013, 08:56 AM
  3. 2001 900 STS won't go over 36 mph
    By chiadrum in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-06-2012, 07:39 AM
  4. 750 stx wont go over 20 MPH
    By ppickard in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-06-2011, 09:01 AM
  5. HELP!! VX110 won't go over 35 mph
    By terkkata in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 06-19-2010, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •